Bug 43530 - [Android] Resuming app throws IllegalStateException from fragment manager
Summary: [Android] Resuming app throws IllegalStateException from fragment manager
Status: RESOLVED DUPLICATE of bug 42075
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-19 07:39 UTC by Rogier van der Hee
Modified: 2016-12-11 09:08 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 42075

Description Rogier van der Hee 2016-08-19 07:39:29 UTC
Hi, my app crashed while resuming my app (using the new AppCompatMode):

	Java.Lang.IllegalStateException: Fragment does not have a view

System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw():0
 Java.Interop.JniEnvironment+InstanceMethods.CallNonvirtualVoidMethod(JniObjectReference instance, JniObjectReference type, Java.Interop.JniMethodInfo method, Java.Interop.JniArgumentValue* args):0
 Java.Interop.JniPeerMembers+JniInstanceMethods.InvokeVirtualVoidMethod(System.String encodedMember, IJavaPeerable self, Java.Interop.JniArgumentValue* parameters):0
 Android.App.Activity.OnStart():0
 Xamarin.Forms.Platform.Android.FormsAppCompatActivity.OnStart():0
 Android.App.Activity.n_OnStart(IntPtr jnienv, IntPtr native__this):0
    (wrapper dynamic-method) System.Object:7d33a1d0-6157-4eb0-a07e-ee501a177a11 (intptr,intptr)
    --- End of managed exception stack trace ---
 java.lang.IllegalStateException: Fragment does not have a view
 android.support.v4.app.Fragment$1.onFindViewById(Fragment.java:1933):0
 android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1057):0
 android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1252):0
 android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1234):0
 android.support.v4.app.FragmentManagerImpl.dispatchActivityCreated(FragmentManager.java:2046):0
 android.support.v4.app.Fragment.performActivityCreated(Fragment.java:1989):0
 android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1092):0
 android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1252):0
 android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1234):0
 android.support.v4.app.FragmentManagerImpl.dispatchActivityCreated(FragmentManager.java:2046):0
 android.support.v4.app.FragmentController.dispatchActivityCreated(FragmentController.java:174):0
 android.support.v4.app.FragmentActivity.onStart(FragmentActivity.java:598):0
 md5b60ffeb829f638581ab2bb9b1a7f4f3f.FormsAppCompatActivity.n_onStart(Native Method):0
 md5b60ffeb829f638581ab2bb9b1a7f4f3f.FormsAppCompatActivity.onStart(FormsAppCompatActivity.java:120):0
 android.app.Instrumentation.callActivityOnStart(Instrumentation.java:1237):0
 android.app.Activity.performStart(Activity.java:6268):0
 android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2379):0
 android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2476):0
 android.app.ActivityThread.-wrap11(ActivityThread.java):0
 android.app.ActivityThread$H.handleMessage(ActivityThread.java:1344):0
 android.os.Handler.dispatchMessage(Handler.java:102):0
 android.os.Looper.loop(Looper.java:148):0
 android.app.ActivityThread.main(ActivityThread.java:5417):0
 java.lang.reflect.Method.invoke(Native Method):0
 com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:726):0
 com.android.internal.os.ZygoteInit.main(ZygoteInit.java:616):0
Comment 1 Rui Marinho 2016-08-22 17:54:14 UTC
Hi this should be fixed in latest pre releases.

*** This bug has been marked as a duplicate of bug 42075 ***
Comment 2 Cliff Cawley 2016-09-14 04:54:17 UTC
I can't monitor the status of the duplicate bug 42075 because it's marked as private :(