Bug 43505 - OutOfMemory when building Android project: System.Object:__icall_wrapper_mono_gc_alloc_vector
Summary: OutOfMemory when building Android project: System.Object:__icall_wrapper_mono...
Status: RESOLVED DUPLICATE of bug 43188
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Performance / Memory Issues (show other bugs)
Version: 6.0.2 (C7SR1)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-18 11:09 UTC by Thomas Van den Bossche
Modified: 2017-05-02 19:54 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 43188

Description Thomas Van den Bossche 2016-08-18 11:09:03 UTC
This only happens when building our Android project and can't be reproduced consistently.
It seems to happen after a couple of builds and deploys to a device.

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Warning: System.OutOfMemoryException: Out of memory
  at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_gc_alloc_vector (intptr,intptr,intptr)
  at (wrapper alloc) System.Object:AllocVector (intptr,intptr)
  at Mono.Cecil.PE.ImageReader.ReadSectionData (Mono.Cecil.PE.Section section) <0xd7dd9f0 + 0x0005f> in <filename unknown>:0 
  at Mono.Cecil.PE.ImageReader.ReadSections (UInt16 count) <0xd7dd7e8 + 0x000f3> in <filename unknown>:0 
  at Mono.Cecil.PE.ImageReader.ReadImage () <0xd7dd300 + 0x00113> in <filename unknown>:0 
  at Mono.Cecil.PE.ImageReader.ReadImageFrom (System.IO.Stream stream) <0xd7dced0 + 0x0004b> in <filename unknown>:0 
  at Mono.Cecil.ModuleDefinition.ReadModule (System.IO.Stream stream, Mono.Cecil.ReaderParameters parameters) <0xd7dccb8 + 0x0004f> in <filename unknown>:0 
  at Mono.Cecil.ModuleDefinition.ReadModule (System.String fileName, Mono.Cecil.ReaderParameters parameters) <0xd7dcb78 + 0x00047> in <filename unknown>:0 
  at Mono.Cecil.AssemblyDefinition.ReadAssembly (System.String fileName, Mono.Cecil.ReaderParameters parameters) <0xd7dcb38 + 0x00017> in <filename unknown>:0 
  at Xamarin.Android.Tuner.DirectoryAssemblyResolver.ReadAssembly (System.String file) <0xd7dc978 + 0x000eb> in <filename unknown>:0  (MH.MobileApps.NewsApp.Android)

Details about the software versions:
=== Xamarin Studio Business ===

Version 6.0.2 (build 73)
Installation UUID: c8d9d174-a2c8-4101-870c-d07ece81c653
Runtime:
	Mono 4.4.2 (mono-4.4.0-branch-c7sr1/f72fe45) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404020011

=== Xamarin.Profiler ===

Version: 0.34.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.3 (10183.3)
Build 7D175

=== Xamarin.Mac ===

Not Installed

=== Xamarin.Android ===

Version: 6.1.2.21 (Xamarin Business)
Android SDK: /Users/thomasvdb/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		6.0   (API level 23)

SDK Tools Version: 25.1.7
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Not Installed

=== Xamarin.iOS ===

Version: 9.8.2.22 (Xamarin Business)
Hash: f37444a
Branch: cycle7-sr1
Build date: 2016-07-28 12:17:02-0400

=== Xamarin Inspector ===

Version: 0.9.0.14
Hash: 4d868da
Branch: master
Build date: Mon Jun 13 19:14:13 UTC 2016

=== Build Information ===

Release ID: 600020073
Git revision: a6f7a24a9723a2d4f5d33c176615b0d44703ab5b
Build date: 2016-07-26 13:36:15-04
Xamarin addins: f5acb37866a0141bc5ddbe95118f18dae4014568
Build lane: monodevelop-lion-cycle7-sr1

=== Operating System ===

Mac OS X 10.11.6
Darwin ICTADMINs-MBP.rug.adroot 15.6.0 Darwin Kernel Version 15.6.0
    Thu Jun 23 18:25:34 PDT 2016
    root:xnu-3248.60.10~1/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Xamarin Inspector 0.9.0.14
Comment 1 Greg Munn 2016-08-18 14:25:50 UTC
Not 100% sure but this might be a duplicate of bug #43188
Comment 2 Jeffrey Stedfast 2017-05-02 19:54:43 UTC

*** This bug has been marked as a duplicate of bug 43188 ***