Bug 43489 - Archiving iOS apps does not recognize Xamarin.Insights is enabled in my app
Summary: Archiving iOS apps does not recognize Xamarin.Insights is enabled in my app
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: 6.1.0 (C8)
Hardware: PC Mac OS
: --- normal
Target Milestone: (C8)
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2016-08-17 19:55 UTC by Kyle White
Modified: 2016-09-05 13:10 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Kyle White 2016-08-17 19:55:10 UTC
1) Create a new iOS app
2) Add the Xamarin.Insights package
3) Add your XamarinInsightsApiKey property to your project file
4) Archive the app for publishing

Expected result: The archive should contain the API key and therefore the Archives screen should show Insights is enabled and whether or not the dSYMs have been uploaded.

Actual result: the Archives screen shows "Insights not enabled"

This works correctly for Android apps.

Screencast: http://screencast.com/t/1L2dsifC7iz
XS Information and logs: https://gist.github.com/anonymous/6374b876272d075c6b337891adbc24fb
Comment 2 Kyle White 2016-08-17 20:07:30 UTC
This had to regress at some point, but it's currently broke in Stable (C7SR1) so its not a regression from stable per se.
Comment 3 Jeffrey Stedfast 2016-08-19 20:41:43 UTC
How do you get access to the Insights API Key? I'll need a way to get access to this in the msbuild logic (which is where the archive logic lives).
Comment 4 Jeffrey Stedfast 2016-08-24 18:36:20 UTC
PR @ https://github.com/xamarin/xamarin-macios/pull/656
Comment 5 Jeffrey Stedfast 2016-08-25 13:47:59 UTC
This has been merged now
Comment 6 Kyle White 2016-08-29 21:16:38 UTC
Looks like this fix was also ported to C8/Xcode8. I have verified it is working in recent XI from Xcode branch, 9.99.5.40.

I will comment again and verify when I can test it in Master.
Comment 7 Parmendra Kumar 2016-09-05 13:10:15 UTC
I have checked this issue with latest Master build xamarin.ios-9.11.0.148_46e6f069199da64c59042191fdba20304157e6d9 and observed that this issue has been fixed.

Screencast: http://www.screencast.com/t/jnu69ZvFODm

Hence closing this issue.

EnvironmentInfo:
Xamarin Studio  6.1 (build 5398)
Mono 4.6.0 (mono-4.6.0-branch/6fa66df) (64-bit)
Xcode 7.3.1 (10188.1)
Build 7D1014
Xamarin.Mac: 2.10.0.89 (Xamarin Enterprise)
Xamarin.iOS: 9.11.0.148 (Xamarin Enterprise)
Xamarin.Android: 7.0.0.12 (Xamarin Enterprise)
Mac OS X 10.11.5