Bug 43468 - Building Forms or Android projects is raising a System.Runtime warning about version mismatch
Summary: Building Forms or Android projects is raising a System.Runtime warning about ...
Status: RESOLVED DUPLICATE of bug 30821
Alias: None
Product: Compilers
Classification: Mono
Component: C# (show other bugs)
Version: 4.6.0 (C8)
Hardware: PC Mac OS
: Normal major
Target Milestone: 4.6.0 (C8)
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2016-08-17 15:47 UTC by Manish Sinha
Modified: 2016-08-22 15:03 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: XS 6.1.0.5338 (860f5d2) + Mono 4.6.0.150 + XA 6.2.0.35

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 30821

Description Manish Sinha 2016-08-17 15:47:43 UTC
Steps to reproduce

1. Install XS
2. Create an Android or Forms App
3. Build in Debug mode

Expected: No warnings should be raised, especially the ones which the user cannot do anything about
Actual: The user gets a warning which they cannot do anything with

Assuming assembly reference `System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' matches assembly `System.Runtime, Version=4.1.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. You may need to supply runtime policy (CS1701)

XS Info: http://xqa.blob.core.windows.net/gist/log-2c09c439a7004c6cb9dfd0f6e590a77f.txt
Comment 1 Matt Gerber 2016-08-18 14:43:00 UTC
I am also getting this error after upgrading to the latest beta of Xamarin Studio (6.1 build 5345).
Comment 2 Peter Collins 2016-08-18 15:32:37 UTC
Diagnostic build output from an XA project that should emit zero warnings and errors:
http://xqa.blob.core.windows.net/gist/log-33333ed3739a4640930ba1227879e57e.txt

As stated, this is a regression from stable C7SR1 builds of Mono and XA. I am only able to reproduce this on macOS.
Comment 3 Marek Safar 2016-08-22 15:03:25 UTC

*** This bug has been marked as a duplicate of bug 30821 ***