Bug 43362 - Event seems broken since 4.0.0
Summary: Event seems broken since 4.0.0
Status: CONFIRMED
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms (show other bugs)
Version: 4.0.0
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-15 19:59 UTC by Poil
Modified: 2018-03-14 11:34 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 43362 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Poil 2016-08-15 19:59:00 UTC
Keepass2 autotype is no more working on Mono 4.0.0 and newer, last working version is 3.2.8

Ref. https://bugs.launchpad.net/ubuntu/+source/keepass2/+bug/1611652
Ref. https://sourceforge.net/p/keepass/bugs/1561/
Comment 2 Marek Safar 2016-08-16 07:44:18 UTC
Could you be more specific on what is not working and ideally describe steps how to reproduce it?
Comment 3 Poil 2016-08-18 19:28:07 UTC
Hi,

Install mono, keepass2 :)
In keepass :
* Add an entry
** Title : the name of a terminal where you can type something in, example "Terminal"
** User name : foo
** Password : bar


In the terminal :
keepass2 --auto-type

On mono 3.2.8 (and before) you will have : foobar "enter"
On mono 4.x nothing 

Best regards
Comment 4 najoll 2017-05-23 14:14:05 UTC
Is more information needed on this? The problem is affecting me - it renders my password manager useless - and, as I can tell from a bugtracker elsewhere, at least several other people too.
Comment 5 najoll 2017-06-14 00:57:17 UTC
Some update - I don't think it was a Mono update - has fixed the problem. Hooray!
Comment 6 Poil 2017-06-15 06:15:22 UTC
He is wrong, he have Mono from Ubuntu1404. https://sourceforge.net/p/keepass/bugs/1561/
Comment 7 Marek Safar 2018-03-13 11:07:06 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and reopen the bug report.

Thank you!
Comment 8 Poil 2018-03-13 15:27:24 UTC
Hi,

I'm still experiencing this issue, what informations do you need ?

Best regards,