Bug 43354 - Button IsEnabled binding is position dependent
Summary: Button IsEnabled binding is position dependent
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.2
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 58996 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-15 16:37 UTC by Sylvain Gravel
Modified: 2017-08-24 17:01 UTC (History)
4 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Sylvain Gravel 2016-08-15 16:37:47 UTC
If I set my Command binding after my IsEnabled binding, teh button will always start as enabled, regardless of binding value returned.

            <Button Margin="0, 40, 0, 0"
                    HorizontalOptions="FillAndExpand"
                    Text="{Binding TextProvider, Converter={StaticResource LanguageConverter}, ConverterParameter='Login'}"
                    TextColor="{StaticResource ContrastColor}"
                    Command="{Binding LoginToServerCommand}"
                    IsEnabled="{Binding HasCredentials}"/>

If you ivert last 2 lines, you will get the issue even if HasCredentials is false.
Comment 1 Samantha Houts [MSFT] 2016-09-12 18:29:53 UTC
Should be fixed in 2.3.3-pre1. Thank you!
Comment 2 Paul DiPietro [MSFT] 2017-08-24 17:01:14 UTC
*** Bug 58996 has been marked as a duplicate of this bug. ***