Bug 43316 - Native References in iOS Binding projects do not build in VS
Summary: Native References in iOS Binding projects do not build in VS
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.1.2 (C7SR1)
Hardware: PC Mac OS
: Highest major
Target Milestone: 4.3.1 (C9SR1)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-12 16:32 UTC by Bill Holmes
Modified: 2018-03-30 01:04 UTC (History)
20 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Solution for testing (30.60 KB, application/zip)
2016-08-12 16:32 UTC, Bill Holmes
Details
Simple sample project (9.81 KB, application/x-zip-compressed)
2017-12-13 18:28 UTC, drungrin
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Bill Holmes 2016-08-12 16:32:15 UTC
Created attachment 17010 [details]
Solution for testing

Open the attached solution file and attempt to build.

Expected Results:
App builds

Actual Results:
The "PrepareNativeReferences" task failed unexpectedly.
Comment 2 Bill Holmes 2016-08-16 19:44:06 UTC
I am 95% sure that I created this in Xamarin Studio.  The latest stable.

Version 6.0.2 (build 73)
Comment 3 Daniel Cazzulino 2016-08-16 20:25:40 UTC
Then they are generating a SLN file in VS2012 format :(
Comment 4 John Miller [MSFT] 2016-08-18 12:52:17 UTC
The solution still reproduces the same issue in VS 2015. Full stack:

The "PrepareNativeReferences" task failed unexpectedly.
System.ArgumentException: Path cannot be the empty string or all whitespace.
   at System.IO.Directory.CreateDirectory(String path)
   at Xamarin.VisualStudio.Build.TaskRunner.WriteEmptyFile(Task task, String file) in C:\Users\builder\data\lanes\3544\fcbe0828\source\xamarinvs\src\MSBuild\Xamarin.VisualStudio.Build\TaskRunner.cs:line 143
   at Xamarin.VisualStudio.Build.TaskRunner.CreateOutputItem(Task task, ITaskCallback taskCallback, ITaskItem item) in C:\Users\builder\data\lanes\3544\fcbe0828\source\xamarinvs\src\MSBuild\Xamarin.VisualStudio.Build\TaskRunner.cs:line 131
   at Xamarin.VisualStudio.Build.TaskRunner.CreateOutputItems(Task task, ITaskCallback taskCallback, IEnumerable items) in C:\Users\builder\data\lanes\3544\fcbe0828\source\xamarinvs\src\MSBuild\Xamarin.VisualStudio.Build\TaskRunner.cs:line 122
   at Xamarin.VisualStudio.Build.TaskRunner.Run(Task task) in C:\Users\builder\data\lanes\3544\fcbe0828\source\xamarinvs\src\MSBuild\Xamarin.VisualStudio.Build\TaskRunner.cs:line 106
   at Xamarin.iOS.Tasks.PrepareNativeReferences.Execute() in C:\Users\builder\data\lanes\3544\fcbe0828\source\xamarinvs\src\MSBuild\Xamarin.iOS.Tasks\Tasks\PrepareNativeReferences.cs:line 18
   at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
   at Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__26.MoveNext()	MyLibFw			

However, I removed the Native Reference in the binding project and re-added using the Add Native Reference menu and now it's build OK.
Comment 5 John Miller [MSFT] 2016-08-18 12:54:32 UTC
In addition to Comment #4, the Output shows that things might not be working as expected:

>------ Build started: Project: MyLibFw, Configuration: Debug Any CPU ------
>  Generated session id: 1056179c54ea1548787829aba6b7efb9
>  Generated build app name: MyLibFw
>  Connecting to Mac server 10.211.55.2...
>C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(1728,5): warning MSB3341: Could not resolve reference "Native References/MyLibFw.framework". If this reference is required by your code, you may get compilation errors.
>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.ObjCBinding.CSharp.targets(84,3): warning : Access to the path 'C:\TestAdHocApp\MyLibFw\Native References\MyLibFw.framework' is denied.
>C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(2940,5): warning MSB9004: ManifestResourceWithNoCulture item type is deprecated. Emit EmbeddedResource items instead, with metadata WithCulture='false', Type='Resx', and optional LogicalName.
>  MyLibFw -> C:\TestAdHocApp\MyLibFw\bin\Debug\MyLibFw.dll
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
Comment 6 xamarin-release-manager 2016-08-18 16:42:36 UTC
Fixed in version 99.0.0.3416 (master)

Author: Adrian Alonso
Commit: 7b03c8f0d512865b2fed787fb15f98c41b6493c7 (xamarin/XamarinVS)
Comment 7 xamarin-release-manager 2016-08-18 16:47:18 UTC
Fixed in version 4.2.0.543 (cycle8)

Author: Adrian Alonso
Commit: f808eccb48eefb3c380e8f421dadc7cfdd3ba14e (xamarin/XamarinVS)
Comment 8 Danish Akhtar 2016-09-15 06:47:49 UTC
I have checked this issue with latest master XVS 99.0.0.3568 and with C8 XVS 4.2.0.680 and observed that I am still getting this issue, getting an error message while building the attached solution in VS.

Hence Reopening this issue.

Build output: https://gist.github.com/atin360/7cbd50bc32a6bb2b7884cc888750ad59
error: https://gist.github.com/atin360/41b3f66225bb580dc47d0367204aacb1
Env info: https://gist.github.com/atin360/41b3f66225bb580dc47d0367204aacb1
Comment 12 xamarin-release-manager 2016-10-14 14:25:21 UTC
Fixed in version 4.3.0.61 (master)

Author: Jose Gallardo
Commit: 12199db353f08b49df6e23c23380f95402dac063 (xamarin/XamarinVS)
Comment 13 xamarin-release-manager 2016-10-14 14:25:36 UTC
Fixed in version 4.2.1.2 (cycle8)

Author: Jose Gallardo
Commit: 7ed0cc84a943d0b27292c224b55563acb99c81ff (xamarin/XamarinVS)
Comment 14 Sunil Kumar 2016-10-14 18:59:11 UTC
I have checked this issue with C8 Xamarin.VisualStudio_4.2.1.2_7ed0cc84a943d0b27292c224b55563acb99c81ff + xamarin.ios-10.0.2.2_ec01be03ba39338126a43196be1f15c5bba81734 and with latest Master Xamarin.VisualStudio_4.3.0.61_12199db353f08b49df6e23c23380f95402dac063 + xamarin.ios-10.1.0.184_2c950a84ea9275f4b61302adaacc37c9fb594d69 and observed that now attached sample builds successfully without any error.

Screencast(C8): http://www.screencast.com/t/Hpm37kEFzV
Screencast(Master): http://www.screencast.com/t/WBXbeasFJr

Hence closing this issue.

Environment info:
Cycle 8: https://gist.github.com/Prashant360/0faab40fa363c29bea48d6996f832bb2
Master: https://gist.github.com/Prashant360/d4c3b88a20e3eafeeea135dbcf4ff1ac
Comment 15 Joao Silva 2016-11-02 17:41:49 UTC
1>------ Build started: Project: MyLibFw, Configuration: Debug Any CPU ------
1>  Generated session id: dd61f7490a18d66afe2e24fa6a9c7d37
1>  Generated build app name: MyLibFw
1>  Connecting to Mac server 10.200.40.128...
1>C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(1728,5): warning MSB3341: Could not resolve reference "MyLibFw.framework". If this reference is required by your code, you may get compilation errors.
1>C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(2940,5): warning MSB9004: ManifestResourceWithNoCulture item type is deprecated. Emit EmbeddedResource items instead, with metadata WithCulture='false', Type='Resx', and optional LogicalName.
1>  MyLibFw -> D:\Examples\TestAdHocApp\TestAdHocApp\MyLibFw\bin\Debug\MyLibFw.dll
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

This isn't fixed and I can't release my product because I can't add an essencial SDK to it.
Comment 16 Joao Silva 2016-11-02 17:44:40 UTC
Forgot this, sorry.
Doesn't work on stable nor on beta channels:

Xamarin   4.2.1.52 (76d5fac)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.0.2.37 (ce955cc)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.2.1.4 (316e533)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 17 Simon Chopin 2017-02-03 09:13:32 UTC
Still doesn't work. ALso, I noted the size of my .a archive is down to 0 after the first build attempt.

The reference was first introduced in a Xamarin Studio Mac environment, where it builds correctly. I have tried removing in on VS and adding it back again, to no avail.

The status of this bug needs to be changed to reflect.

Versions:

Microsoft Visual Studio Community 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Xamarin   4.2.2.11 (00fa5cc)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.0.2.42 (501e63c)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.3.1.8 (7beaef4)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 18 John Miller [MSFT] 2017-02-03 14:11:44 UTC
@Joao and @Simon,

I'll reopen the bug report. Can you provide a sample project and diagnostic build output for something that does not work? 

Thanks!
Comment 19 Lyndon Hughey 2017-02-17 15:34:59 UTC
I'm having the same problem with another solution.  I'm receiving the same error messages, and the size of my .a file is 0 bytes.

Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Xamarin   4.2.2.11 (00fa5cc)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.0.2.42 (501e63c)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.3.1.8 (7beaef4)
Comment 20 Emanuel 2017-06-07 18:12:47 UTC
I cannot reproduce this issue with the attached sample, I'm able to build and run the app (which shows the correct result).

Besides everything worked for me, I got the warning message @Joao mentioned before, but that shouldn't prevent anyone from building and using native references. That warning is wrong and misleading, and we're working to fix it.

Regarding the issue with Native Static References (.a), I've opened a new bug for that: https://bugzilla.xamarin.com/show_bug.cgi?id=57247


I'm marking this bug as Resolved Fixed, since I couldn't reproduce the issue. If you're still experiencing it feel free to reopen this bug, and please attach a sample solution where we can repro it.

Thanks!
Comment 21 drungrin 2017-12-13 18:00:33 UTC
The bug still occurs with latest updated visual studio.

VisualStudio.15.Release/15.5.1+27130.2003

Xamarin   4.8.0.753 (6575bd113)
Extensão do Visual Studio para habilitar o desenvolvimento para o Xamarin.iOS e o Xamarin.Android.

Xamarin Designer   4.8.183 (2577c82ea)
Visual Studio extension to enable Xamarin Designer tools in Visual Studio.

Xamarin.Android SDK   8.1.0.24 (HEAD/9cfa7836b)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   11.6.1.2 (6857dfc)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.

Steps to Reproduce:

1. File -> New Project -> iOS Binding (Create the NativeLibrary1)
2. Right Click on Solution -> Add New Project -> iOS Binding (Create the NativeLibrary2)
3. On NativeLibrary1, Add NativeLibrary2 as a Reference.
4. Build NativeLibrary1

Actual Result:
2>C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\MSBuild\Xamarin\iOS\Xamarin.iOS.ObjCBinding.CSharp.targets(58,3): error : Metadata file `/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.iOS/NativeLibrary2.dll' could not be found

Expected Result:
Build with no errors.
Comment 22 drungrin 2017-12-13 18:28:51 UTC
Created attachment 25995 [details]
Simple sample project
Comment 23 John Miller [MSFT] 2017-12-13 18:38:14 UTC
Hi Drungrin,

That issue looks to manifest a different error than this bug was for. To make sure it gets eyes on it ASAP, please use the Help > Report a Problem feature from within Visual Studio. 

Thanks!
Comment 24 drungrin 2017-12-13 18:48:04 UTC
Hi John Miller. 

Did as you asked. But the issue is that I cann't build Native References in iOS Binding projects as the title, so the issue was partially solved for me.
Comment 25 Prince Kumar 2018-02-07 08:21:26 UTC
While I am binding my ios SDK (.a) file, the final step to create the .dll fails. 


I am getting this error
"/Library/Frameworks/Mono.framework/Versions/5.4.1/lib/mono/msbuild/15.0/bin/Microsoft.Common.CurrentVersion.targets(5,5): Warning MSB9004: ManifestResourceWithNoCulture item type is deprecated. Emit EmbeddedResource items instead, with metadata WithCulture='false', Type='Resx', and optional LogicalName. (MSB9004) (smisdkXamarin)"

The build shows 0 errors and 1 warning. 

Please let me know how to proceed. 

Any lead is appreciated. 

TIA. 

-Prince
Comment 26 Prince Kumar 2018-02-07 08:30:26 UTC
Please find the details below:

Xamarin build v: 7.3.3. (build 12)
Comment 27 Prince Kumar 2018-03-14 07:10:04 UTC
The same error I am getting even after the update to 7.4. Am I missing something?
Comment 28 John Lanz 2018-03-29 00:04:56 UTC
This is happening to me as well....

References/AccountKit.framework' could not be found.	

Event though it is clearly there.


Microsoft Visual Studio Professional 2017 
Version 15.6.4
VisualStudio.15.Release/15.6.4+27428.2015
Microsoft .NET Framework
Version 4.7.02556

Installed Version: Professional

VisualStudio.Mac   1.0
Mac Extension for Visual Studio

Xamarin   4.9.0.752 (0faa808ee)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin Designer   4.10.58 (cee1369d0)
Visual Studio extension to enable Xamarin Designer tools in Visual Studio.

Xamarin.Android SDK   8.2.0.16 (HEAD/a78295902)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   11.8.1.28 (3979d08)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.
Comment 29 dan 2018-03-30 01:00:36 UTC
Same problem: 1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\Bin\Microsoft.Common.CurrentVersion.targets(1950,5): warning MSB3341: Could not resolve reference "C:\Git\jamclone\jamrecord\jamrecord.iOS\Native References\WebRTC.framework". If this reference is required by your code, you may get compilation errors.


However, the file is clearly there, and the library even builds, but with the following output:

1>------ Rebuild All started: Project: WebRTC, Configuration: Debug Any CPU ------
1>  Connecting to Mac server 192.168.86.220...
1>  Connecting to Mac server 192.168.86.220...
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\Bin\Microsoft.Common.CurrentVersion.targets(1950,5): warning MSB3341: Could not resolve reference "C:\Git\jamclone\jamrecord\jamrecord.iOS\Native References\WebRTC.framework". If this reference is required by your code, you may get compilation errors.
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.ObjCBinding.CSharp.targets(60,3): warning : bgen: The member 'StringForDeviceType' is decorated with [Static] and its container class WebRTC.UIDevice_RTCDevice is decorated with [Category] this leads to hard to use code. Please inline StringForDeviceType into UIKit.UIDevice class.
1>  WebRTC -> C:\Git\jamclone\WebRTC\bin\Debug\WebRTC.dll
========== Rebuild All: 1 succeeded, 0 failed, 0 skipped ==========
Comment 30 dan 2018-03-30 01:04:28 UTC
Microsoft Visual Studio Community 2017 
Version 15.6.4
VisualStudio.15.Release/15.6.4+27428.2015
Microsoft .NET Framework
Version 4.7.03056

Installed Version: Community

Visual C++ 2017   00369-60000-00001-AA567
Microsoft Visual C++ 2017

Visual F# Tools 10.1 for F# 4.1   00369-60000-00001-AA567
Microsoft Visual F# Tools 10.1 for F# 4.1

Application Insights Tools for Visual Studio Package   8.11.10212.1
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2017   15.0.40314.0
ASP.NET and Web Tools 2017

ASP.NET Core Razor Language Services   1.0
Provides languages services for ASP.NET Core Razor.

ASP.NET Web Frameworks and Tools 2017   5.2.51214.0
For additional information, visit https://www.asp.net/

AWS Toolkit for Visual Studio 2017   1.14.1.6
AWS Toolkit for Visual Studio 2017.
Copyright 2011-2018 Amazon.com, Inc. or its affiliates. All Rights Reserved.

Release notes: https://aws-vs-toolkit.s3.amazonaws.com/versioninfo.html

This software includes third party software subject to the following copyrights:
- Logging from log4net, Apache License 
  [http://logging.apache.org/log4net/license.html]
- Putty for PPK to PEM conversion, MIT license 
  [http://www.chiark.greenend.org.uk/~sgtatham/putty/licence.html]
- NGit for AWS Elastic Beanstalk incremental push
  [https://github.com/mono/ngit/blob/master/NGit.license.txt]
- NSch dependency for NGit
  [https://github.com/mono/ngit/blob/master/NSch.license.txt]
- Sharpen dependency for NGit
  [https://github.com/mono/ngit/blob/master/Sharpen/AssemblyInfo.cs]
- ICSharpCode.SharpZipLib dependency for NGit
  [http://www.icsharpcode.net/opensource/sharpziplib/]
- Mono.Posix.dll and Mono.Security.dll dependencies for NGit
  [http://mono-project.com/FAQ:_Licensing#Licensing]
- MPFProj for Visual Studio Project Framework
  [http://mpfproj10.codeplex.com/license]
- JSON Checker for JSON validation
  [http://www.raboof.com/projects/jsonchecker/]
- Newtonsoft Json.NET
  [http://www.newtonsoft.com/json] 
- YamlDotNet
  [http://aaubry.net/pages/yamldotnet.html] 
    

Azure App Service Tools v3.0.0   15.0.40215.0
Azure App Service Tools v3.0.0

Azure Data Lake Node   1.0
This package contains the Data Lake integration nodes for Server Explorer.

Azure Data Lake Tools for Visual Studio   2.2.9000.1
Microsoft Azure Data Lake Tools for Visual Studio

Azure Data Lake Tools for Visual Studio   2.2.9000.1
Microsoft Azure Data Lake Tools for Visual Studio

Azure Functions and Web Jobs Tools   15.0.40215.0
Azure Functions and Web Jobs Tools

C# Tools   2.7.0-beta3-62715-05. Commit Hash: db02128e6e3c4bdfc93e6ec425ac9162b4d4fe80
C# components used in the IDE. Depending on your project type and settings, a different version of the compiler may be used.

Common Azure Tools   1.10
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

Cookiecutter   15.6.18072.2
Provides tools for finding, instantiating and customizing templates in cookiecutter format.

Fabric.DiagnosticEvents   1.0
Fabric Diagnostic Events

GitHub.VisualStudio   2.4.3.1737
A Visual Studio Extension that brings the GitHub Flow into Visual Studio.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

JavaScript UWP Project System   2.0
JavaScript UWP Project System

Markdown Editor   1.11.231
A full featured Markdown editor with live preview and syntax highlighting. Supports GitHub flavored Markdown.

Merq   1.1.17-rc (cba4571)
Command Bus, Event Stream and Async Manager for Visual Studio extensions.

Microsoft Azure HDInsight Azure Node   2.2.9000.1
HDInsight Node under Azure Node

Microsoft Azure Hive Query Language Service   2.2.9000.1
Language service for Hive query

Microsoft Azure Service Fabric Tools for Visual Studio   2.0
Microsoft Azure Service Fabric Tools for Visual Studio

Microsoft Azure Stream Analytics Language Service   2.2.9000.1
Language service for Azure Stream Analytics

Microsoft Azure Stream Analytics Node   1.0
Azure Stream Analytics Node under Azure Node

Microsoft Azure Tools   2.9
Microsoft Azure Tools for Microsoft Visual Studio 2017 - v2.9.51212.2

Microsoft Continuous Delivery Tools for Visual Studio   0.3
Simplifying the configuration of continuous build integration and continuous build delivery from within the Visual Studio IDE.

Microsoft JVM Debugger   1.0
Provides support for connecting the Visual Studio debugger to JDWP compatible Java Virtual Machines

Microsoft MI-Based Debugger   1.0
Provides support for connecting Visual Studio to MI compatible debuggers

Microsoft Visual C++ Wizards   1.0
Microsoft Visual C++ Wizards

Microsoft Visual Studio Tools for Containers   1.1
Develop, run, validate your ASP.NET Core applications in the target environment. F5 your application directly into a container with debugging, or CTRL + F5 to edit & refresh your app without having to rebuild the container.

Microsoft Visual Studio VC Package   1.0
Microsoft Visual Studio VC Package

Mono Debugging for Visual Studio   4.9.11-pre (71eb098)
Support for debugging Mono processes with Visual Studio.

Node.js Tools   1.4.11027.3
Adds support for developing and debugging Node.js apps in Visual Studio

NuGet Package Manager   4.6.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

ProjectServicesPackage Extension   1.0
ProjectServicesPackage Visual Studio Extension Detailed Info

Python   15.6.18072.2
Provides IntelliSense, projects, templates, debugging, interactive windows, and other support for Python developers.

Python - Django support   15.6.18072.2
Provides templates and integration for the Django web framework.

Python - IronPython support   15.6.18072.2
Provides templates and integration for IronPython-based projects.

Python - Profiling support   15.6.18072.2
Profiling support for Python projects.

SQL Server Data Tools   15.1.61801.210
Microsoft SQL Server Data Tools

ToolWindowHostedEditor   1.0
Hosting json editor into a tool window

TypeScript Tools   15.6.20202.3
TypeScript Tools for Microsoft Visual Studio

Visual Basic Tools   2.7.0-beta3-62715-05. Commit Hash: db02128e6e3c4bdfc93e6ec425ac9162b4d4fe80
Visual Basic components used in the IDE. Depending on your project type and settings, a different version of the compiler may be used.

Visual C++ for Linux Development   1.0.8
Visual C++ for Linux Development

Visual Studio Code Debug Adapter Host Package   1.0
Interop layer for hosting Visual Studio Code debug adapters in Visual Studio

Visual Studio Tools for Apache Cordova   15.123.7102.2
Visual Studio Tools for Apache Cordova

Visual Studio Tools for CMake   1.0
Visual Studio Tools for CMake

Config for above bug:

Visual Studio Tools for Unity   3.6.0.5
Visual Studio Tools for Unity

Visual Studio Tools for Universal Windows Apps   15.0.27428.01
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

VisualStudio.Mac   1.0
Mac Extension for Visual Studio

Xamarin   4.9.0.752 (0faa808ee)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin Designer   4.10.58 (cee1369d0)
Visual Studio extension to enable Xamarin Designer tools in Visual Studio.

Xamarin.Android SDK   8.2.0.16 (HEAD/a78295902)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   11.8.1.28 (3979d08)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.