Bug 43313 - Adding an item to ListView ItemSource has unexpected animation with different height rows and HasUnevenRows is true
Summary: Adding an item to ListView ItemSource has unexpected animation with different...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.3.2
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 44830 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-12 16:22 UTC by John Miller [MSFT]
Modified: 2017-03-22 19:41 UTC (History)
11 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project (42.83 KB, application/zip)
2016-08-12 16:22 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Miller [MSFT] 2016-08-12 16:22:21 UTC
Created attachment 17009 [details]
Sample Project

**Overview:**

   This has spawned from https://bugzilla.xamarin.com/show_bug.cgi?id=28277. While investigating #28277, I noticed that adding an item to the ItemsSource of a ListView does not behave as expected. It has a strange animation while inserting and does not show the newly added item at the bottom of the list. When all row heights are uniform, things are working as expected.
   
**Steps to Reproduce:**

   1. Run the attached sample on iOS simulator
   2. In the first tab, press Add Item

**Actual Results:**

   See screencast: http://screencast.com/t/Ngk1XS7nY

   There is a visual animation that seems to be the entire list reloading. Then, it is not offset to the right position for the newly added row anyway.
   
**Expected Results:**

   Exactly the same results as adding an item when all rows are uniform. Only that row should animate into the bottom of the UITableView.

   See screencast: http://screencast.com/t/KKOpFYs4X0d
   
**Build Date & Platform:**

   XF 2.3.2.118-pre1
   iOS 9.3
   
**Additional Information:**

   Use the Second Tab of the sample project to see the desired results and how it behaves when all rows are uniform.
Comment 1 Ray Kelly 2016-09-13 23:21:20 UTC
Any update on this bug?  This is holding up my release.  Thank you.
Comment 2 E.Z. Hart [MSFT] 2016-10-10 16:42:19 UTC
*** Bug 44830 has been marked as a duplicate of this bug. ***
Comment 3 E.Z. Hart [MSFT] 2016-11-10 17:20:12 UTC
PR: https://github.com/xamarin/Xamarin.Forms/pull/454
Comment 4 Samantha Houts [MSFT] 2016-12-15 19:37:51 UTC
Should be fixed in 2.3.4-pre2. Thank you!
Comment 5 Parmendra Kumar 2017-02-02 17:23:41 UTC
I have checked this issue with latest Xamarin.Forms version 2.3.4.184-pre1 and I am still getting same issue with iOS 10.2.

Screencast: https://www.screencast.com/t/xhk5eaObOGCH

Hence reopened this issue.

EnvironmentInfo: 
Xamarin Studio Enterprise 6.2 (build 1799)
Installation UUID: 05cfbdd7-b4af-41cd-945a-9db8b054b749
Mono 4.8.0 (mono-4.8.0-branch/afc625c) (64-bit)
Xcode 8.2.1 (11766.1)
Xamarin.iOS: 10.4.0.105 (Xamarin Enterprise)
Xamarin.Android: 7.1.0.31 (Xamarin Enterprise)
Mac OS X 10.12.2
Comment 6 Rui Marinho 2017-03-22 19:41:45 UTC
Should be fixed on 2.3.4-pre6