Bug 43301 - Error in generated part of xaml page
Summary: Error in generated part of xaml page
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.1
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 44807 46272 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-12 11:45 UTC by om2804
Modified: 2017-01-25 08:44 UTC (History)
7 users (show)

Tags: xaml ac
Is this bug a regression?: ---
Last known good build:


Attachments
Repro project (260.20 KB, application/x-zip-compressed)
2017-01-10 17:37 UTC, E.Z. Hart [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description om2804 2016-08-12 11:45:31 UTC
Error in generated part of xaml page

namespace Firm.MVVM.Xamarin.Samples.Views {
    using System;
    using Xamarin.Forms;
    using Xamarin.Forms.Xaml;
    
    
    public partial class Page2 : global::Firm.MVVM.PageBase {
        
        [System.CodeDom.Compiler.GeneratedCodeAttribute("Xamarin.Forms.Build.Tasks.XamlG", "0.0.0.0")]
        private void InitializeComponent() {
            this.LoadFromXaml(typeof(Page2));
        }
    }
}

Namespace "Xamarin.Forms" try finding in namespace "Firm.MVVM.Xamarin.Forms".

Must be

using System;
using Xamarin.Forms;
using Xamarin.Forms.Xaml;

namespace Firm.MVVM.Xamarin.Samples.Views {
...

Or

namespace Lasmera.MVVM.Xamarin.Samples.Views {
    using System;
    using global::Xamarin.Forms;
    using global::Xamarin.Forms.Xaml;
Comment 1 Stephane Delcroix 2016-09-28 10:58:57 UTC
*** Bug 44807 has been marked as a duplicate of this bug. ***
Comment 2 Stephane Delcroix 2016-10-12 07:14:30 UTC
should be fixed in 2.3.4-pre1
Comment 3 Parmendra Kumar 2016-11-25 07:16:13 UTC
I have checked this issue with latest X.F 2.3.4-pre1 and observed that this issue doesn't fixed completely. I have checked this issue on VS and XS. To verify this issue I have followed duplicate bug #44807

1. On XS I am still getting same issue.

Screencast: http://www.screencast.com/t/hue7x93VAJ

2. On VS I am getting error only UWP,WindowsPhone environment.

Screencast: http://www.screencast.com/t/rcfPirJ6O

Hence closing this issue.
Comment 4 E.Z. Hart [MSFT] 2017-01-09 21:26:55 UTC
Still happening with 2.3.4.3-nightly.
Comment 5 E.Z. Hart [MSFT] 2017-01-10 17:37:20 UTC
Created attachment 19157 [details]
Repro project
Comment 7 Stephane Delcroix 2017-01-11 12:10:42 UTC
Please make sure:

 - that you updated the XF package in ALL projects of your solution,
 - that you cleaned the solution, and removed the obj/ and bin/ folder,
 - that you restarted your IDE (so the new Tasks assembly is loaded),
 - that you rebuild, and it now works.

WORKSFORME in 2.3.4.3-nightly
Comment 8 E.Z. Hart [MSFT] 2017-01-11 16:09:01 UTC
Confirmed - if I update to the latest nightly, clean the solution, manually delete the bin and obj folders, and restart VS, it works.
Comment 9 Stephane Delcroix 2017-01-25 08:44:24 UTC
*** Bug 46272 has been marked as a duplicate of this bug. ***