This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 43287 - System modal windows during release build
Summary: System modal windows during release build
Status: CLOSED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 6.1.2 (C7SR1)
Hardware: PC Windows
: --- normal
Target Milestone: 7.1 (C9)
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2016-08-11 19:59 UTC by Kerry Graham
Modified: 2016-12-30 09:45 UTC (History)
7 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Kerry Graham 2016-08-11 19:59:08 UTC
When performing a release build from Visual Studio, there are no less than 20 system modal windows that pop up and take over my PC, pulling focus way from anything else I'm doing (reading email, writing in a document, etc.)

Really?

Who thought this was a good plan?

Each of the windows is some sort of msbuild window with a crossarm.exe as the running program.

---------------------------------------------
Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.6.00081

Installed Version: Professional

LightSwitch for Visual Studio 2013   06177-179-0050036-02120
Microsoft LightSwitch for Visual Studio 2013

Team Explorer for Visual Studio 2013   06177-179-0050036-02120
Microsoft Team Explorer for Visual Studio 2013

Visual Basic 2013   06177-179-0050036-02120
Microsoft Visual Basic 2013

Visual C# 2013   06177-179-0050036-02120
Microsoft Visual C# 2013

Visual C++ 2013   06177-179-0050036-02120
Microsoft Visual C++ 2013

Visual F# 2013   06177-179-0050036-02120
Microsoft Visual F# 2013

Visual Studio 2013 Code Analysis Spell Checker   06177-179-0050036-02120
Microsoft® Visual Studio® 2013 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

Application Insights Tools for Visual Studio Package   1.0
Application Insights Tools for Visual Studio

ASP.NET and Web Tools   12.3.50717.0
Microsoft Web Developer Tools contains the following components:
Support for creating and opening ASP.NET web projects
Browser Link: A communication channel between Visual Studio and browsers
Editor extensions for HTML, CSS, and JavaScript
Page Inspector: Inspection tool for ASP.NET web projects
Scaffolding: A framework for building and running code generators
Server Explorer extensions for Microsoft Azure Websites
Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Microsoft Azure

ASP.NET Web Frameworks and Tools 2012.2   4.1.21001.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.20703.0
For additional information, visit http://www.asp.net/

Common Azure Tools   1.2
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

Microsoft Azure Mobile Services Tools   1.2
Microsoft Azure Mobile Services Tools

NuGet Package Manager   2.8.60318.734
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

Office Developer Tools for Visual Studio 2013 ENU   12.0.30626
Microsoft Office Developer Tools for Visual Studio 2013 ENU

PowerShell Tools   1.2
Provides file classification services using PowerShell

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SAPReferenceManager   1.0
Manages References to Shared Projects

SQL Server Data Tools   12.0.30919.1
Microsoft SQL Server Data Tools

Windows Installer XML Toolset   3.8.1128.0
Windows Installer XML Toolset version 3.8.1128.0
Copyright (c) Outercurve Foundation. All rights reserved.

Windows Phone 8.1 SDK Integration   1.0
This package integrates the tools for the Windows Phone 8.1 SDK into the menus and controls of Visual Studio.

Workflow Manager Tools 1.0   1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin   4.1.2.18 (fcbe082)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   6.1.2.21 (1cf254d)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   9.8.2.22 (f37444a)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 2 Jonathan Pryor 2016-08-19 16:03:33 UTC
Dean: Looks like we should audit our System.Diagnostics.Process usage and ensure we always specify ProcessStartInfo.CreateNoWindow=true:

https://msdn.microsoft.com/en-us/library/system.diagnostics.processstartinfo(v=vs.110).aspx

We might want to also consider setting ProcessStartInfo.WindowStyle to ProcessWindowStyle.Hidden:

https://msdn.microsoft.com/en-us/library/system.diagnostics.processstartinfo.windowstyle(v=vs.110).aspx
https://msdn.microsoft.com/en-us/library/system.diagnostics.processwindowstyle(v=vs.110).aspx
Comment 3 dean.ellis 2016-10-07 14:17:40 UTC
PR up on https://github.com/xamarin/xamarin-android/pull/257
Comment 4 dean.ellis 2016-10-07 15:20:09 UTC
Fixed in xamarin-android/master/3fe80c52
Comment 6 Akhilesh kumar 2016-12-30 09:45:48 UTC
As we did not get any response on this bug from last couple of months, so I am closing this issue with "No Response" status.

Please feel free to reopen(or file a new issue) if anyone still observing same issue.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.