Bug 43234 - System.TimeZoneNotFoundException trying to build Xamarin.Forms-master Solution
Summary: System.TimeZoneNotFoundException trying to build Xamarin.Forms-master Solution
Status: RESOLVED DUPLICATE of bug 42082
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- blocker
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-10 16:10 UTC by daniel.garcia
Modified: 2016-08-10 21:31 UTC (History)
2 users (show)

Tags: Android ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 42082

Description daniel.garcia 2016-08-10 16:10:06 UTC
# Steps to reproduce
1 - Download solution from site https://github.com/xamarin/Xamarin.Forms
2 - Open it on Visual Studio 2015
3 - Install Bing Maps
4 - Install Android SDK
5 - Build Solution

# Expected behavior
Compile OK

# Actual behavior
System.TimeZoneNotFoundException on Projects:
    Xamarin.Forms.Platform.Android.AppLinks
    Xamarin.Forms.ControlGallery.Android


# Supplemental info (logs, images, videos)
   Windows 10
   Visual Studio 2015 Update 3
   Time Zone UTC-06:00 Guadalajara, Ciudad de México, Monterrey

# Test environment (full version information)
Comment 1 E.Z. Hart [MSFT] 2016-08-10 21:27:24 UTC

*** This bug has been marked as a duplicate of bug 42082 ***
Comment 2 E.Z. Hart [MSFT] 2016-08-10 21:31:17 UTC
This will be fixed in an upcoming version of Xamarin Android; in the meantime, you can work around it by changing your time zone to "Central Time (United States and Canada)" (see https://bugzilla.xamarin.com/show_bug.cgi?id=42133).