Bug 43193 - Keep CurrentCulture in async/await
Summary: Keep CurrentCulture in async/await
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: 4.5.X
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2016-08-09 14:15 UTC by Alexey
Modified: 2016-08-31 05:57 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alexey 2016-08-09 14:15:29 UTC
If using asyn\await, the CurrentUICulture is lost
.NET 4.5 and Mono 4.5.1 

private static async Task ClutureTest()
{
   //default culture is 'ru'
   Thread.CurrentThread.CurrentUICulture = new CultureInfo("en");
   Console.WriteLine(Thread.CurrentThread.CurrentUICulture.Name); // print 'en'
   await Task.Delay(1);
   Console.WriteLine(Thread.CurrentThread.CurrentUICulture.Name); // print 'ru'
}


.NET 4.6 - work fine

Looks like http://stackoverflow.com/a/30664385
Comment 1 Marek Safar 2016-08-31 05:57:39 UTC
Fixed in master