Bug 43056 - "InitializeComponent() The Call is Ambiguous" in projects with AssemblyName!=DefaultNamespace
Summary: "InitializeComponent() The Call is Ambiguous" in projects with AssemblyName!=...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Xamarin.Forms Add-in (show other bugs)
Version: 6.1.0 (C8)
Hardware: PC Mac OS
: High normal
Target Milestone: (C8)
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2016-08-04 13:49 UTC by David Karlaš
Modified: 2016-08-10 14:58 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description David Karlaš 2016-08-04 13:49:44 UTC
Repro steps:
1) Create new Xamarin.Forms project in Xamarin Studio.
2) Change "Assembly name" or "Default Namespace" setting in project settings.
3) Reopen solution and open .xaml.cs file, it should have error.

For more details look at Bug 41572.
Comment 3 David Karlaš 2016-08-10 13:06:28 UTC
Wrench is failing to build this with some weird error unrelated to this change... Since this change is not platform specific I'm marking this as fixed.
Comment 4 xamarin-release-manager 2016-08-10 13:17:47 UTC
Fixed in version 6.1.0.5319 (cycle8)

Author: David Karla??
Commit: f6e44295daf47eccf62168386ba8c7d18ae97121 (xamarin/md-addins)
Included in Commit: 9229b563a9e12834a3169f0087bffc472847a81d (mono/monodevelop)

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.