Bug 43035 - Failed build errors don't appear in the Error window
Summary: Failed build errors don't appear in the Error window
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Xamarin.Forms (show other bugs)
Version: 4.1.0 (C7)
Hardware: PC Mac OS
: Normal normal
Target Milestone: 4.3.0 (C9)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-03 18:23 UTC by John Miller [MSFT]
Modified: 2016-12-23 10:58 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Video to the problem (4.19 MB, video/mp4)
2016-08-04 06:58 UTC, Fredy Wenger
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description John Miller [MSFT] 2016-08-03 18:23:34 UTC
**Overview:**

   A failed build has errors that don't appear in the Error window in VS. The errors are present in the Output window.

**Steps to Reproduce:**

   Unclear, I was not able to reproduce on my machine yet, but I don't have Update 3 installed.

**Actual Results:**

   See attached video recording of customers environment demonstrating the issue.

**Expected Results:**

   CS#### Errors should appear in the Error window.

**Build Date & Platform:**

   Xamarin 4.1.1.3
   
Microsoft Visual Studio Professional 2015
Version 14.0.25402.00 Update 3 RC
Microsoft .NET Framework
Version 4.6.01038
Comment 2 Fredy Wenger 2016-08-04 06:58:00 UTC
Created attachment 16889 [details]
Video to the problem
Comment 3 Fredy Wenger 2016-08-04 07:17:21 UTC
Additional informations:

Detailed description:

The problem occurs only with my Xamarin.forms project.

Behavior Xamarin.forms project:
I do a mistake in a module (e.g. add wezuuuwe in the code)
I rebuild the project or debug...
- In the under taskbar, the text "Build failed" is showed
- The error list window is NOT activated/showed automatically
- The error list shows 0 Errors 
- The error is showed in the output-window (as error)
- I have to search the whole output-window for errors, note the module and 
  the line number for each error and then load the module and go to the line
  number manually

Behavior other project (VB.net) SAME VS2015 installation:
I do a mistake in a module (e.g. add wezuuuwe in the code)
I rebuild the project or debug
- VS give out a message, that there are build errors
- I see the error in the error list 
- If I click on the error, VS loads the module with the error and goes to the
  error line automatically
=> That’s the NORMAL behavior if VS
Comment 4 Adrian Alonso 2016-08-19 14:07:39 UTC
Hi, does it happen only with Android projects in the context of Xamarin.Forms solution?  Other kind of errors are shown in the Error List?
Comment 5 Fredy Wenger 2016-08-19 17:24:16 UTC
Only Xamarin.forms but also iOS
Comment 6 Miguel de Icaza [MSFT] 2016-11-22 20:54:38 UTC
Information was provided
Comment 7 dean.ellis 2016-11-23 15:34:17 UTC
@john can we get the diagnostic log data (rather than a screencast) It makes it easier to search through the data and diagnose.
Comment 8 John Miller [MSFT] 2016-11-23 16:37:36 UTC
@dean, No. I was not able to reproduce this. @Fredy, can you upload this information?
Comment 9 Fredy Wenger 2016-11-23 17:01:26 UTC
In don't know, what you mean with "diagnostic log data".
I need a step-by-step advise, how to do this (then I will do it)
So... step-by-step-advise please
Comment 10 Jose Gallardo 2016-11-24 20:54:50 UTC
Hi Fredy,

I think what Dean is asking for is diagnostic build output for your project.

To get the diagnostic Build Output:

Go to the menu "Tools - Options" and from the left panel: "Projects And Solutions - Build And Run" and change "MSBuild Output Verbosity" to "Diagnostic", and then build. Copy the Build Output from the Output window and share it (maybe in a gist or as a zip file).

Hope that helps. Let me know if you need more detail. 

Thanks!
Comment 11 Fredy Wenger 2016-11-30 10:20:17 UTC
Hi Jose
Thanks for the advise...
I have done what you have suggested... and see a very strange behavior:
- The option was set to "Minimal"
- I have changed the option to "Diagnostic" 
- Then, I have added a wrong code
=> The compiler has stopped and showed the error the in the error-window
  => Like it should work
=> Then I HAVE CHANGED BACK THE OPTION TO "Minimal" (like it was before)
=> The compiler has stopped and showed the error the in the error-window !?!
=> So it seems as to CHANGE (TOUCH) the option-setting has solved the problem!
I also have restarted VS (after set the option back to "Minimal" to be sure that it also works after a restart (and... it works)


So.. it seems, as the problem is solved now.

It seems to be a bug in VS2015 or the Xamarin-VS integration SW.
=> If it reappears (what I don't hope), I will write here...
Comment 12 Adrian Alonso 2016-12-22 18:01:33 UTC
Thanks Fredy, I will mark the bug as resolved. Please let us know and feel free to reopen it.
Comment 13 Saurabh 2016-12-23 10:58:28 UTC
As per Comment#11, this is working fine and I also checked it at my end with latest Cycle9 builds (XVS 4.3.0.498) and getting build errors in Error log pad.

Microsoft Visual Studio Enterprise 2015
Version 14.0.25422.01 Update 3
Microsoft .NET Framework
Version 4.6.01055

Installed Version: Enterprise

Xamarin   4.3.0.498 (46382df)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin Inspector Support   1.0.0.0 (1f3067d)
Adds support for inspecting Xamarin and WPF apps.

Xamarin.Android   7.1.0.14 (cea7c6e)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.4.0.49 (3282166)
Visual Studio extension to enable development for Xamarin.iOS.