Bug 43022 - ZipArchive.Entries is not updated when ZipArchiveEntry is deleted
Summary: ZipArchive.Entries is not updated when ZipArchiveEntry is deleted
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: SharpZipLib (show other bugs)
Version: 4.7.X
Hardware: Other Other
: --- normal
Target Milestone: Untriaged
Assignee: João Matos
URL:
Depends on:
Blocks:
 
Reported: 2016-08-03 07:09 UTC by Tim Jones
Modified: 2016-08-04 17:36 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Tim Jones 2016-08-03 07:09:44 UTC
Steps to repro:

1. Open a ZipArchive, which contains an existing file - for example, test.txt.
2. Get the ZipArchiveEntry for this file - i.e. zipArchive.GetEntry("test.txt").
3. Delete the ZipArchiveEntry - zipArchiveEntry.Delete().

Expected outcome:
zipArchive.Entries should no longer contain the deleted ZipArchiveEntry. This is what happens in the .NET Framework implementation.

Actual outcome:
zipArchive.Entries does contain the deleted ZipArchiveEntry.

From reading the source code, it looks like ZipArchiveEntry.Delete() calls Archive.zipFile.RemoveEntry(entry) - which removes the entry from SharpCompress.Archive.Zip.ZipArchive's Entries collection, but not System.IO.Compression.ZipArchive.Entries.
Comment 1 João Matos 2016-08-04 12:32:08 UTC
Pushed PR: https://github.com/mono/mono/pull/3357

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.