Bug 43018 - unable to select an event handler which has been already defined
Summary: unable to select an event handler which has been already defined
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS Designer (show other bugs)
Version: 4.1.0 (C7)
Hardware: PC Windows
: --- blocker
Target Milestone: 4.2.0 (C8)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-02 21:50 UTC by reemfz
Modified: 2016-08-05 19:38 UTC (History)
11 users (show)

Tags: BZSRC7
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description reemfz 2016-08-02 21:50:53 UTC
# Steps to reproduce
This bug can be easily reproduced in both XS and VS
Add two buttons to the view
select the first button and add a new event handler to touch up event
select the second button and click the drop down menu of the touch up and nothing will show up

# Expected behavior
i should be able to select event handlers which have been already defined once.

# Actual behavior
drop down menu is ALWAYS empty.  Practically useless. 

# Supplemental info (logs, images, videos)


# Test environment (full version information)
Comment 1 reemfz 2016-08-03 19:03:53 UTC
please let me know if you need me to provide screen cast.
should be easy to reproduce on your end.
Comment 3 Alan McGovern 2016-08-04 22:25:15 UTC
Ben, if this is being marked as a c8 blocker then can we check if the issue still exists in c8? It looks like it was filed against c7.
Comment 4 xamarin-release-manager 2016-08-05 10:56:29 UTC
Fixed in version 4.2.0.434 (cycle8)

Author: Alan McGovern
Commit: 779db564494ff84d3685b51a739bd085b1c935c1 (xamarin/md-addins)
Included in Commit: d9483c3df8952c5e57f2776f83d9f3516fb6821d (xamarin/XamarinVS)
Comment 5 reemfz 2016-08-05 16:43:05 UTC
Hi Ben,

it appears the bug was fixed in cycle8, however, if you need me to provide additional info or a screen cast, I am happy to do so.

Best,