Bug 43004 - mcs.exe freezes
Summary: mcs.exe freezes
Status: RESOLVED DUPLICATE of bug 42606
Alias: None
Product: Runtime
Classification: Mono
Component: JIT (show other bugs)
Version: 4.5.X
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-02 17:54 UTC by af4178a2
Modified: 2016-09-06 00:38 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 42606

Description af4178a2 2016-08-02 17:54:00 UTC
Since the update to build 4.5.2.799-0nightly1 (Debian GNU/Linux) it is no longer possible to compile. The compiler freezes and the process causes 100% cpu load.

Command line: /usr/lib/mono/4.5/mcs.exe Program.cs /target:exe /reference:/usr/lib/mono/4.5/System.dll /reference:/usr/lib/mono/4.5/System.Core.dll /reference:/usr/lib/mono/4.5//mscorlib.dll /warn:4

mcs does not output anything

Program.cs is a simple Main method with "Hello World".
Comment 1 Łukasz Domeradzki 2016-08-07 03:28:58 UTC
Probably very similar to https://bugzilla.xamarin.com/show_bug.cgi?id=42606
Comment 2 Bernhard Urban 2016-09-06 00:38:34 UTC
very likely a duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=42606

reopen if this isn't the case.

*** This bug has been marked as a duplicate of bug 42606 ***