Bug 42970 - F# Fails out of the box with Visual Studio 2015
Summary: F# Fails out of the box with Visual Studio 2015
Status: RESOLVED DUPLICATE of bug 38570
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General (show other bugs)
Version: 4.1.0 (C7)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-02 03:19 UTC by Cody Beyer (MSFT)
Modified: 2016-08-04 11:16 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 38570

Description Cody Beyer (MSFT) 2016-08-02 03:19:43 UTC
# Description

F# applications cannot be built and references cannot be added to F# projects due to incompatibilities between the default version of F# in Visual Studio 2015 (F# 4) and the framework version expected by Xamarin (F# 3)

Installing F# 3 does allow F# project so operate and build.

# Screenshots

https://db.tt/qB7LMKUw

https://db.tt/D8LBHKNm

# Steps to Reproduce

	1. Open Visual Studio
	2. Select File > New > Project > Visual F# > Android > Blank App (Android)
	3. Right click on References and select "Add Reference"

# Expected Results

Add reference dialog should appear

# Actual Results

Error is thrown as described in screenshots

# Versions

Microsoft Visual Studio Professional 2015
Version 14.0.25424.00 Update 3
Microsoft .NET Framework
Version 4.6.01038

Installed Version: Professional

LightSwitch for Visual Studio 2015   00322-40000-00000-AA256
Microsoft LightSwitch for Visual Studio 2015

Visual Basic 2015   00322-40000-00000-AA256
Microsoft Visual Basic 2015

Visual C# 2015   00322-40000-00000-AA256
Microsoft Visual C# 2015

Visual C++ 2015   00322-40000-00000-AA256
Microsoft Visual C++ 2015

Visual F# 2015   00322-40000-00000-AA256
Microsoft Visual F# 2015

Windows Phone SDK 8.0 - ENU   00322-40000-00000-AA256
Windows Phone SDK 8.0 - ENU

Application Insights Tools for Visual Studio Package   7.1.00719.1
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2015.1   14.1.20624.0
ASP.NET and Web Tools 2015.1

ASP.NET Web Frameworks and Tools 2012.2   4.1.41102.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.40314.0
For additional information, visit http://www.asp.net/

Azure App Service Tools v2.8.1   14.0.11123.0
Azure App Service Tools v2.8.1

Common Azure Tools   1.8
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

Microsoft .NET Core Tools (Preview 2)   14.1.20624.0
Microsoft .NET Core Tools (Preview 2)

Microsoft Azure Mobile Services Tools   1.4
Microsoft Azure Mobile Services Tools

NuGet Package Manager   3.5.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   14.0.60519.0
Microsoft SQL Server Data Tools

TypeScript   1.8.35.0
TypeScript tools for Visual Studio

Visual Studio Tools for Universal Windows Apps   14.0.25420.01
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

Xamarin   4.1.2.18 (fcbe082)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin Inspector Support   0.9.0.14 (4d868da)
Adds support for inspecting Xamarin and WPF apps.

Xamarin.Android   6.1.2.21 (1cf254d)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   9.8.2.22 (f37444a)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 1 Miguel de Icaza [MSFT] 2016-08-03 15:06:08 UTC

*** This bug has been marked as a duplicate of bug 38570 ***
Comment 2 Jason Imison 2016-08-04 11:16:23 UTC
PR here - https://github.com/xamarin/xamarin-android/pull/141