Bug 42969 - Apps won't launch on simulators or devices using Xcode8 beta 4
Summary: Apps won't launch on simulators or devices using Xcode8 beta 4
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: 6.1.0 (C8)
Hardware: Macintosh Mac OS
: High blocker
Target Milestone: iOS10/Xcode8/OSX10.12
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2016-08-01 23:07 UTC by kkurz
Modified: 2016-08-19 14:34 UTC (History)
10 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description kkurz 2016-08-01 23:07:35 UTC
Updated iPhone to iOS 10 beta 4. Cannot load even a simple project on the device. Xcode 8 beta 4 builds/installs fine. Xamarin test project attached. It fails with the following error:

/Applications/Xamarin Studio.app/Contents/Resources/lib/monodevelop/AddIns/MonoDevelop.IPhone/mlaunch.app/Contents/MacOS/mlaunch -sdkroot "/Applications/Xcode-beta.app/Contents/Developer" -installdev "/Users/kkurz/Git/softphones/Softphone.ios/bin/iPhone/Debug/build-iphone8.1-10.0/Softphone.ios.app" "--devname=Studio B"
error HE0004: Could not load the framework 'DVTDocumentation' (path: /Applications/Xcode-beta.app/Contents/SharedFrameworks/DVTDocumentation.framework/DVTDocumentation): dlopen(/Applications/Xcode-beta.app/Contents/SharedFrameworks/DVTDocumentation.framework/DVTDocumentation, 1): Library not loaded: @rpath/libswiftos.dylib
  Referenced from: /Applications/Xcode-beta.app/Contents/SharedFrameworks/libswiftFoundation.dylib
  Reason: image not found

Application could not be uploaded to the device.

Xamarin info:

=== Xamarin Studio Professional ===

Version 6.1 (build 5235)
Installation UUID: 582dde06-8a89-43f2-9b6c-510e4fbebc32
Runtime:
	Mono 4.4.0 (mono-4.4.0-branch/fcf7a6d) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000148

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Not Installed

=== Xamarin Android Player ===

Not Installed

=== Apple Developer Tools ===

Xcode 8.0 (11222.4)
Build 8S188o

=== Xamarin.Mac ===

Not Installed

=== Xamarin.iOS ===

Version: 9.99.0.326 (Visual Studio Professional)
Hash: d29eb7a
Branch: cycle8
Build date: 2016-07-15 18:47:59-0400

=== Build Information ===

Release ID: 601005235
Git revision: ec12ea3dd5b59de84d5007bff97f969439ab61cb
Build date: 2016-07-14 10:04:37-04
Xamarin addins: 2fd80118a267f656798bd002da0841811d1acb70
Build lane: monodevelop-lion-cycle8

=== Operating System ===

Mac OS X 10.12.0
Darwin Kyles-MacBook-Pro.local 16.0.0 Darwin Kernel Version 16.0.0
    Tue Jul 26 18:32:56 PDT 2016
    root:xnu-3789.1.4.1.1~1/RELEASE_X86_64 x86_64
Comment 1 kkurz 2016-08-01 23:09:25 UTC
Annoyingly, your upload limit is beyond even a simple repro .zip. You'll have to reproduce yourself (create a new single-view app and attempt to install on beta 4 with Xamarin preview 1).
Comment 2 Sebastien Pouliot 2016-08-02 01:50:44 UTC
This is a known issue starting with beta 4.

The current (first) preview works with beta 2 and beta 3. A newer preview will soon be available to support beta 4.

-> Xamarin Studio / iOS addin
Comment 4 kkurz 2016-08-02 15:45:36 UTC
FYI, you changed the title to specify simulators. My bug report is against running on a device. So maybe ALL launches fail, but physical devices were what I was testing against.
Comment 5 Sebastien Pouliot 2016-08-02 15:54:40 UTC
Thanks for replying. The fix for device is a subset (does not require a new iOS addin) of the complete fix I already had (and does not require a new XS build).

A workaround is to:

a. download the fixed `mlaunch` tool from https://bosstoragemirror.blob.core.windows.net/public-builder/mlaunch

b. copy it over the current XS version of `mlaunch` 

> cp mlaunch "/Applications/Xamarin Studio.app/Contents/Resources/lib/monodevelop/AddIns/MonoDevelop.IPhone/mlaunch.app/Contents/MacOS"

That will fix the device (only) support when used with Xcode8 beta 4.
Comment 6 kkurz 2016-08-02 15:56:44 UTC
Ok, I'll do that. Do you have any ETA on an official preview supporting beta 4? There's been major changes to the CallKit API since XS Preview 1 and I can't move forward until I have a new preview. Sorry for thread-jack, just figured I finally had someone who was answering questions quickly... ;)
Comment 7 Sebastien Pouliot 2016-08-02 16:16:59 UTC
The 2nd preview will come out as soon as we complete our support for beta 4 and QA confirms every tools (XI, XS/VS addin and designer) works well together. I'd guess later this week but it depends on the number of surprises (like this bug) that are found across products.

Internal builds [1] of XI will be available sooner - but they come without any validation straight out of our build bots (pre-QA).

The SDK is open source [2] so you can track when the update to callkit will be merged and download the associated package.

[1] https://github.com/xamarin/xamarin-macios/wiki
[2] https://github.com/xamarin/xamarin-macios/commits/xcode8
Comment 10 Sebastien Pouliot 2016-08-04 17:46:50 UTC
@Jeff any ETA ?
Comment 11 Christer Nordvik 2016-08-04 20:38:27 UTC
I tried the fix from comment 5 but my deployment just hangs and never completes. No longer gives the error message but doesn't seem to deploy either. Do you need any more details or should I wait for the Preview 2?
Comment 13 Christer Nordvik 2016-08-09 07:19:11 UTC
Preview 2 works but XS doesn't attach to debugger but at least the deployment works. I'll create a new bug for the debugger since it isn't listed as a known limitation of Preview 2.
Comment 14 GouriKumari 2016-08-09 21:24:45 UTC
Please find below link to XS build that gives device and simulator support with Xcode8-beta4 and Xcode8-beta5. This build is a preview and is not fully tested. We would like your feedback on this build. 

http://download.xamarin.com/hotfixes/XamarinStudio-6.1.0.5316.dmg.
Comment 15 Christer Nordvik 2016-08-10 07:35:57 UTC
My app just crashes when launching on the simulator. Check below for the complete crash. 


Process:               FotMob [13915]
Path:                  /Users/USER/Library/Developer/CoreSimulator/Devices/5EEE47B4-E8B1-4AEB-84D6-EE0C99C19E7A/data/Containers/Bundle/Application/8FB91B15-F7B7-42B4-9E7B-231977C845D4/FotMob.app/FotMob
Identifier:            FotMob
Version:               46.0 (371)
Code Type:             X86 (Native)
Parent Process:        launchd_sim [13828]
Responsible:           FotMob [13915]
User ID:               501

Date/Time:             2016-08-10 08:29:42.617 +0200
OS Version:            Mac OS X 10.11.5 (15F34)
Report Version:        11
Anonymous UUID:        9364C93D-0D27-7CA9-3727-B97B763EB6E8

Sleep/Wake UUID:       68CFCBDA-0B89-46E3-BE76-15DD6C6BD33B

Time Awake Since Boot: 75000 seconds
Time Since Wake:       1700 seconds

System Integrity Protection: enabled

Crashed Thread:        0

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
dyld: launch, loading dependent libraries
DYLD_FALLBACK_LIBRARY_PATH=/Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/usr/lib
DYLD_ROOT_PATH=/Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk
DYLD_FALLBACK_FRAMEWORK_PATH=/Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/System/Library/Frameworks
DYLD_SHARED_REGION=avoid

Dyld Error Message:
  Library not loaded: @rpath/Mono.framework/Mono
  Referenced from: /Users/USER/Library/Developer/CoreSimulator/Devices/5EEE47B4-E8B1-4AEB-84D6-EE0C99C19E7A/data/Containers/Bundle/Application/8FB91B15-F7B7-42B4-9E7B-231977C845D4/FotMob.app/FotMob
  Reason: no suitable image found.  Did find:
	/Users/cnordvik/Library/Developer/CoreSimulator/Devices/5EEE47B4-E8B1-4AEB-84D6-EE0C99C19E7A/data/Containers/Bundle/Application/8FB91B15-F7B7-42B4-9E7B-231977C845D4/FotMob.app/Frameworks/Mono.framework/Mono: required code signature missing for '/Users/cnordvik/Library/Developer/CoreSimulator/Devices/5EEE47B4-E8B1-4AEB-84D6-EE0C99C19E7A/data/Containers/Bundle/Application/8FB91B15-F7B7-42B4-9E7B-231977C845D4/FotMob.app/Frameworks/Mono.framework/Mono'

Binary Images:
    0xa000 -   0x631ff3 +com.mobilefootie.fotmobpro (46.0 - 371) <EC5AAACF-0671-3860-88F7-2D5FEF76FD77> /Users/USER/Library/Developer/CoreSimulator/Devices/5EEE47B4-E8B1-4AEB-84D6-EE0C99C19E7A/data/Containers/Bundle/Application/8FB91B15-F7B7-42B4-9E7B-231977C845D4/FotMob.app/FotMob
  0xb6d000 -   0xb92f03 +dyld_sim (360.22) <BEC35A92-8B21-3609-A83B-F49ABDF86CCC> /Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/usr/lib/dyld_sim
0x8fec7000 - 0x8fefb727  dyld (360.22) <F2FF555F-3F89-3F21-8761-25A0E3F8282F> /usr/lib/dyld
Comment 16 kkurz 2016-08-16 23:52:02 UTC
After updating to CI build 9eca876 and XS-5341, I'm getting the errors from this original ticket again. I reopened 43323, but thought maybe this was the correct ticket to reopen. Feel free to close one of them, but this needs further investigation. The mlaunch hack described above doesn't fix this either.
Comment 17 kkurz 2016-08-16 23:53:38 UTC
EDIT: This is using Xcode 8 beta 6 and iOS 10 beta 6 devices.
Comment 18 Sebastien Pouliot 2016-08-17 00:02:08 UTC
This is tracked in #43373

Please open new bug reports for new Xcode beta releases. This is often different issues and tracking them from a single bug report only makes the issue confusing (even more if the full version information are not supplied). Thanks!
Comment 19 Mohit Kheterpal 2016-08-19 14:34:39 UTC
As bug 43373 is verified fixed and now user is able to deploy and launch application on device/simulator using Xcode 8 Beta 6 without any error.

XamarinStudio-6.1.0.5345.dmg fc3ab7c0cc891ef8c9867558d026257fc4654758 and /xamarin.ios-9.99.3.8 9eca87665af46375758b14e3b2622122b9cb6032 with Xcode 8 Beta 6

Hence closing this issue by marking it as Verified fixed.