Bug 42792 - Missing Privacy Settings for info.plist
Summary: Missing Privacy Settings for info.plist
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: 6.1.0 (C8)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: (C8)
Assignee: Vincent Dondain [MSFT]
URL:
Depends on:
Blocks: 43897
  Show dependency tree
 
Reported: 2016-07-25 21:44 UTC by kkurz
Modified: 2016-09-06 16:42 UTC (History)
6 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description kkurz 2016-07-25 21:44:50 UTC
iOS 10 made a number of Info.plist strings required when asking permission. You hit some of them, but we use the camera and "NSCameraUsageDescription" was missing. Additionally, the error iOS provides is useless, so it's hard to identify. It just prints [access] private to the console. There may be other missing keys, please see the list here:

https://developer.apple.com/library/prerelease/content/documentation/General/Reference/InfoPlistKeyReference/Articles/CocoaKeys.html
Comment 1 Alex Soto [MSFT] 2016-07-26 04:49:19 UTC
Yes, this key is missing, we should review the document provided in Comment #0 because I was able to spot some others
Comment 2 Sebastien Pouliot 2016-08-04 14:30:08 UTC
@Vincent when it's added to XS please make sure to forward the info the the XVS team. Thanks!
Comment 3 Vincent Dondain [MSFT] 2016-09-01 13:17:59 UTC
Fixed in md-addins/689dd10d5ae0cb2ac0fd0cecc36c2663d2a00d13 and PR for cycle8 https://github.com/xamarin/md-addins/pull/1199
Comment 4 Vincent Dondain [MSFT] 2016-09-01 15:04:01 UTC
Also filed the same bug for the XVS team: https://bugzilla.xamarin.com/show_bug.cgi?id=43942
Comment 5 Mohit Kheterpal 2016-09-06 14:30:11 UTC
I have checked this issue with the build provided in trello card and observed that this issue has been fixed i.e. new privacy keys are added with NSCameraUsageDescription as shown in screencast : http://www.screencast.com/t/gB8mJCJ91O

could you please merge the fix in cycle 8 lane, so that we can close this issue.

thanks
Comment 6 xamarin-release-manager 2016-09-06 15:30:44 UTC
Fixed in version 6.1.0.5421 (cycle8)

Author: Vincent Dondain
Commit: 6dc0a1be813d094af7424e12958a395ddd412581 (xamarin/md-addins)
Included in Commit: 53b1b24fb027adea22d8d6afe9c7d69c626e9bc5 (mono/monodevelop)
Comment 7 Mohit Kheterpal 2016-09-06 16:42:02 UTC
I have checked this issue with latest build of Cycle 8 i.e. XS 6.1.0.5425 and observed that fixed for this issue has been merged with cycle 8.

Hence closing this issue by marking it as Verified.

thanks

Note You need to log in before you can comment on or make changes to this bug.