Bug 42779 - Random crash caused by LogViewProgressMonitor
Summary: Random crash caused by LogViewProgressMonitor
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit (show other bugs)
Version: 6.0.2 (C7SR1)
Hardware: Macintosh Mac OS
: High major
Target Milestone: (C8SR1)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-07-25 11:39 UTC by Alan McGovern
Modified: 2016-10-12 16:26 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Alan McGovern 2016-07-25 11:39:05 UTC
[ERROR] FATAL UNHANDLED EXCEPTION: System.NullReferenceException: Object reference not set to an instance of an object
  at MonoDevelop.Ide.Gui.Components.LogViewProgressMonitor.OnWriteErrorLog (System.String message) [0x00000] in /Users/alan/Projects/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Gui.Components/LogView.cs:737 
  at MonoDevelop.Core.ProgressMonitor.DoWriteErrorLog (System.String message) [0x0001e] in /Users/alan/Projects/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core/ProgressMonitor.cs:622 
  at MonoDevelop.Core.ProgressMonitoring.LogTextWriter.Write (System.String value) [0x0000b] in /Users/alan/Projects/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core.ProgressMonitoring/LogTextWriter.cs:93 
  at MonoDevelop.Core.Execution.OutWriter.WriteOut (System.Object sender, System.String s) [0x00000] in /Users/alan/Projects/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core.Execution/ProcessService.cs:443 
  at MonoDevelop.Core.Execution.ProcessWrapper.CaptureError () [0x0001b] in /Users/alan/Projects/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core.Execution/ProcessWrapper.cs:128 
  at System.Threading.ThreadHelper.ThreadStart_Context (System.Object state) [0x00017] in /private/tmp/source-mono-pango-cfretain-font/bockbuild-pango-cfretain-font/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/threading/thread.cs:68 
  at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x0008d] in /private/tmp/source-mono-pango-cfretain-font/bockbuild-pango-cfretain-font/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/threading/executioncontext.cs:957 
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in /private/tmp/source-mono-pango-cfretain-font/bockbuild-pango-cfretain-font/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/threading/executioncontext.cs:904 
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state) [0x00031] in /private/tmp/source-mono-pango-cfretain-font/bockbuild-pango-cfretain-font/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/threading/executioncontext.cs:893 
  at System.Threading.ThreadHelper.ThreadStart () [0x0000b] in /private/tmp/source-mono-pango-cfretain-font/bockbuild-pango-cfretain-font/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/threading/thread.cs:105 
[MVID] 07b3765e02234806b15dc84437feac0d 5,6,7,8,9
[MVID] 1185435289e34e1cadce088785f7f0be 0
[MVID] 790eb2815d484023b603b5781fc50aea 1,2,3,4
make[1]: *** [run-bundle] Error 1
make: *** [run] Error 2
Alans-MacBook-Pro:md-addins alan$
Comment 1 Oleg Demchenko 2016-09-12 16:57:31 UTC
I can reproduce this crash when running unit tests with UnitTests pad:
https://gist.github.com/olegoid/8261891806c7dd14e7bb4daa95193c85

With Beta(XamarinStudio-6.1.0.5436) and stable(Version 6.0.2 (build 73)) builds.
Comment 2 Oleg Demchenko 2016-09-15 16:47:32 UTC
Moving this bug to SR1 release since we have a workaround for that. Instead of running unit tests from XS users can do it with nunit-console.
Comment 3 xamarin-release-manager 2016-09-16 11:58:26 UTC
Fixed in version 6.2.0.498 (master)

Author: David Karlas??
Commit: a0c88825a8f226f5c7dd7405b1bdb58292f5f5d3 (mono/monodevelop)
Comment 4 xamarin-release-manager 2016-10-12 16:26:42 UTC
Fixed in version 6.1.2.31 (cycle8)

Author: Lluis Sanchez
Commit: e593b3bc388baec5af27b2ca49259f617536e1c9 (mono/monodevelop)

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.