Bug 42718 - Xamarin.Mac Extensions cannot be built on Yosemite as it needs OSX 10.11.4 on above
Summary: Xamarin.Mac Extensions cannot be built on Yosemite as it needs OSX 10.11.4 on...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in (show other bugs)
Version: 6.1.0 (C8)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: (C8)
Assignee: Vincent Dondain [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-07-21 16:53 UTC by Manish Sinha
Modified: 2016-09-08 14:23 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Manish Sinha 2016-07-21 16:53:58 UTC
Steps to reproduce

0. Use Xcode.7.2 (7.3 cant be installed on Yosemite)
1. Use macOS Yosemite
2. Create a Mac Cocoa App
3. Add a mac extension
4. Build

Expected: It should build properly
Actual: Mac extensions need OSX 10.11.4 or above from XCode 7.3 but 7.3 cant be installed on Yosemite


Ide.log: http://storage.bos.internalx.com/QA-xs_mac_uitest_long-cycle8/31/3191078766e49b32edf425106bfb7403ca892958/XQA-XS-Yosemite/TestCreateBuildMacTodayExtension/TestCreateBuildMacTodayExtension.Ide.log
XS Info: http://xqa.blob.core.windows.net/gist/log-33c73c7cbb0c4676aeedb9e43d94960d.txt

Steps and screenshot: http://storage.bos.internalx.com/QA-xs_mac_uitest_long-cycle8/31/3191078766e49b32edf425106bfb7403ca892958/XQA-XS-Yosemite/TestCreateBuildMacTodayExtension/TestReport.html
Comment 1 Vincent Dondain [MSFT] 2016-07-21 17:13:40 UTC
So Mac extensions came on El Cap but Xcode 7.0 to 7.2.1 have OSX 10.11 support. So some extensions that do not require 10.11.4 APIs could still be built on Yosemite.

Therefore the statement: "Xamarin.Mac Extensions cannot be built on Yosemite" is incorrect.

Now the question is do we want templates that can't be ran, because in any case you won't be able to run and debug the extensions on Yosemite.
Comment 2 xamarin-release-manager 2016-07-21 17:28:27 UTC
Fixed in version 6.2.0.209 (master)

Author: Jeffrey Stedfast
Commit: b011bd9886763d7d92efc438f9640f4cd67956fe (xamarin/md-addins)
Included in Commit: baafad5b69f68333b940cc2e78ddd373b907cc60 (mono/monodevelop)
Comment 3 xamarin-release-manager 2016-07-21 17:28:46 UTC
Fixed in version 6.1.0.5259 (cycle8)

Author: Jeffrey Stedfast
Commit: a21e169a9e8e2f437743874f4e6735cb4e48986e (xamarin/md-addins)
Included in Commit: 8c5e22b4feddd6f27b7db65a83ce608be97bfa91 (mono/monodevelop)
Comment 5 xamarin-release-manager 2016-09-06 22:40:47 UTC
Fixed in version 6.1.0.5433 (cycle8)

Author: Jeffrey Stedfast
Commit: cc2219273ac887bfadb17a9c3787d77a987b09f7 (xamarin/md-addins)
Included in Commit: 6c75bc1d4ed7b307d8b520127035a302eb2897e2 (mono/monodevelop)

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.