Bug 42593 - Cannot open the Info.plist in a watchos extension project
Summary: Cannot open the Info.plist in a watchos extension project
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2016-07-15 13:59 UTC by Alan McGovern
Modified: 2016-09-16 09:11 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Alan McGovern 2016-07-15 13:59:02 UTC
I just get this crash:


https://gist.github.com/alanmcgovern/c9343b17d589cee4ee9c5c08b16278f6

ERROR [2016-07-15 14:50:44Z]: 
System.InvalidOperationException: Sequence contains no elements
  at System.Linq.Enumerable.First[TSource] (IEnumerable`1 source) [0x00067] in /private/tmp/source-mono-4.4.0-c7-baseline/bockbuild-mono-4.4.0-c7-baseline/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/System.Core/System/Linq/Enumerable.cs:930 
  at MonoDevelop.IPhone.PlistEditor.WatchCompliationsConfiguration.ConfigureDataSource () [0x000b6] in /Users/alan/Projects/md-addins/MonoDevelop.IPhone/MonoDevelop.IPhone/PlistEditor/WatchCompliationsConfiguration.cs:92 
  at MonoDevelop.IPhone.PlistEditor.WatchCompliationsConfiguration.set_FocusChain (Gtk.Widget[] value) [0x00112] in /Users/alan/Projects/md-addins/MonoDevelop.IPhone/MonoDevelop.IPhone/PlistEditor/WatchCompliationsConfiguration.cs:65 
  at MonoDevelop.IPhone.PlistEditor.IPhonePlistAttachableDisplayBinding+<GetSections>c__Iterator0.MoveNext () [0x0029d] in /Users/alan/Projects/md-addins/MonoDevelop.IPhone/MonoDevelop.IPhone/PlistEditor/IPhonePlistAttachableDisplayBinding.cs:93 
  at MonoDevelop.MacDev.PlistEditor.FriendlyPlistEditorWidget..ctor (Xamarin.MacDev.PObjectContainer plist, IEnumerable`1 sections) [0x000c2] in /Users/alan/Projects/md-addins/MonoDevelop.MacDev/MonoDevelop.MacDev/PlistEditor/FriendlyPlistEditorWidget.cs:57 
  at MonoDevelop.MacDev.PlistEditor.PlistEditorAttachableViewContent..ctor (System.String title, MonoDevelop.MacDev.PlistEditor.PListEditorViewContent content, IEnumerable`1 sections) [0x00006] in /Users/alan/Projects/md-addins/MonoDevelop.MacDev/MonoDevelop.MacDev/PlistEditor/PlistEditorAttachableViewContent.cs:47 
  at MonoDevelop.MacDev.PlistEditor.PlistEditorAttachableDisplayBindingBase.CreateViewContent (MonoDevelop.Ide.Gui.ViewContent content) [0x00007] in /Users/alan/Projects/md-addins/MonoDevelop.MacDev/MonoDevelop.MacDev/PlistEditor/PlistEditorAttachableDisplayBindingBase.cs:60 
  at MonoDevelop.Ide.Gui.DisplayBindingService.AttachSubWindows (IWorkbenchWindow workbenchWindow, IViewDisplayBinding binding) [0x0004c] in /Users/alan/Projects/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Gui/DisplayBindingService.cs:103 
  at MonoDevelop.Ide.Gui.DefaultWorkbench.ShowView (MonoDevelop.Ide.Gui.ViewContent content, Boolean bringToFront, IViewDisplayBinding binding, MonoDevelop.Components.DockNotebook.DockNotebook notebook) [0x0013a] in /Users/alan/Projects/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Gui/DefaultWorkbench.cs:417
Comment 1 Jeffrey Stedfast 2016-07-18 15:55:37 UTC
This should be fixed in git master now (back-ported to cycle8 as well)
Comment 2 xamarin-release-manager 2016-07-18 19:26:11 UTC
Fixed in version 6.1.0.5255 (cycle8)

Author: Jeffrey Stedfast
Commit: bd9f33bcc8ef1ec476b20b377251fb02e0521a7f (xamarin/md-addins)
Included in Commit: 14e5c74bd6c799d3eb83039347191d187d0c13fd (mono/monodevelop)
Comment 3 xamarin-release-manager 2016-09-06 22:40:45 UTC
Fixed in version 6.1.0.5433 (cycle8)

Author: Jeffrey Stedfast
Commit: 85804cef9d9d2d2b3a5cabe11ae6c9eb31bc833d (xamarin/md-addins)
Included in Commit: 6c75bc1d4ed7b307d8b520127035a302eb2897e2 (mono/monodevelop)
Comment 4 Shruti 2016-09-16 09:11:09 UTC
I have verified this issue with the latest master builds as well as latest cycle 8 builds and have observed that the issue is fixed, as now user is successfully able to open the info.plist file for the watch extension project.

Below is the screencast for the same:
http://www.screencast.com/t/q3sJJvYjhlA

Environment information:
Master: https://gist.github.com/sachins360/9020978e369b5ed5d675b43030205164
Cycle 8: https://gist.github.com/Arpit360/df315358fecf770a65c42381f09b3166

Hence, marking this issue as Verified Fixed.

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.