Bug 42554 - Typing into the search box is corrupting memory and crashing
Summary: Typing into the search box is corrupting memory and crashing
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: High blocker
Target Milestone: (C8)
Assignee: Cody Russell
URL:
Depends on:
Blocks:
 
Reported: 2016-07-14 11:41 UTC by Alan McGovern
Modified: 2016-08-16 07:41 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Alan McGovern 2016-07-14 11:41:09 UTC
Repro, just type in the search box: http://screencast.com/t/Iz9cb6jgn

Sample output indicating memory corruption: https://gist.github.com/alanmcgovern/96f5225e1a9e1de535db0a77c2e637ae

Sample crash caused by memory corruption: https://gist.github.com/alanmcgovern/fec347f39b3cfd99267feef57df2eec3
Comment 1 Alan McGovern 2016-07-14 12:13:49 UTC
I started seeing these crashes very recently and I also updated my mono very recently.

I'm using Mono JIT compiler version 4.6.0 (mono-4.6.0-branch/7c372ff Thu Jul 14 02:56:23 EDT 2016) at the moment. This could be a regression in C8 mono.
Comment 6 Shruti 2016-07-22 11:56:19 UTC
*****************
Reproduce Status
*****************
I have tried to reproduce this issue with larger solution with Mono 4.6.0. I have typed multiple times to search box for searching text and used keyboard arrow keys. After using arrow keys, XS get crashed. I am able to reproduce the XS crash behaviour around 3 times but I am getting different exceptions "ObjCRuntime.RuntimeException: Cannot register two managed types "
IDE Log: https://gist.github.com/shrutis360/fa88a07a785809e044bf104413c48b20
XS Crash report: https://gist.github.com/shrutis360/58f9a81bfb0cdc1dae7c2f1042ebc35a
Environment Info: https://gist.github.com/shrutis360/ee87aa52f0f4db66265318690c1998d7
Screencast: http://www.screencast.com/t/W1tPISiVD1S

****************
Verify Status:
*****************
I have checked this issue with patch Mono 4.6.0.56 with multiple behaviour of typo text in search box and used keyboard arrow keys. And XS did not get crashed.
Environment Info:https://gist.github.com/shrutis360/2083aadfc7cb14e760b997234fbaaadc

@Alan, Could you please review it. And I believe we can verify this issue as this issue  is no more exist.
Comment 7 Alan McGovern 2016-07-22 15:29:26 UTC
You triggered the issue with the old build and couldn't with the fixed build, so that looks like the patch worked as expected!
Comment 8 Jatin 2016-08-16 07:41:44 UTC
I have verified this issue with the latest Cycle 8 builds, below is the environment information for the same:
https://gist.github.com/jatin360/bbda969e4628e7aa504070cbcec8e9e0

I have observed that this issue is now foxed, as the XS does not crash when type text in search box and used keyboard arrow keys.

Below is the screencast for the same:
http://www.screencast.com/t/FIRfp8pM

Hence, we can close this issue.