Bug 42530 - Entry.Text not updated when modified by iOS Autocorrect, word suggestions, or spellchecker
Summary: Entry.Text not updated when modified by iOS Autocorrect, word suggestions, or...
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.3.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-07-13 17:58 UTC by Mac Server
Modified: 2016-12-01 14:58 UTC (History)
6 users (show)

Tags: ac
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Mac Server 2016-07-13 17:58:07 UTC
Similar to Bug 37726
Possibly a duplicate of Bug #31422

On iOS devices, when an Entry's text is modified using any of the various typing aid systems (autocorrect, spellcheck, suggestions), the Entry.Text is not modified and still holds the previous value of the text.

Problem outline:
- An entry has text entered via iOS' spellcheck or suggestions, replacing the user's text while typing
- The actual value in Entry.Text does not match the view, allowing users to submit unwanted or incorrect details in their entries

Issue is similar to Bug #37726
https://bugzilla.xamarin.com/show_bug.cgi?id=37726

Also see bug #31422 and comment
https://bugzilla.xamarin.com/show_bug.cgi?id=38265

Issue:
- Affects iOS devices (tested using iOS 9.3);
- When an Entry's text is modified using any of the various typing aid systems (autocorrect, spellcheck,    suggestions), the Entry.Text is not modified and still holds the previous value of the text.
- At the same time, bound model is updated correctly with 'replaced' value.

Expected behavior:
- Entry displays final, actual value that match the value in the model.
Comment 1 Mac Server 2016-07-13 18:02:12 UTC
Also related to Bug #31422
https://bugzilla.xamarin.com/show_bug.cgi?id=31422
Comment 2 adrianknight89 2016-09-30 16:26:43 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/401
Comment 3 Samantha Houts [MSFT] 2016-10-20 19:34:30 UTC
Should be fixed in 2.3.4-pre1. Thank you!
Comment 4 Parmendra Kumar 2016-12-01 14:58:19 UTC
I have verified the related bug #31422 provided in comment #1.

Hence marked this issue as Verified Fixed.

Thanks