Bug 42366 - Exception doesn't include Java native stacktrace anymore
Summary: Exception doesn't include Java native stacktrace anymore
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries (show other bugs)
Version: 6.1.0 (C7)
Hardware: PC Mac OS
: High major
Target Milestone: 6.1.x (C7SR1)
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2016-07-05 19:28 UTC by Jérémie Laval
Modified: 2016-07-18 12:36 UTC (History)
5 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Jérémie Laval 2016-07-05 19:28:45 UTC
With the switch to the referencesource version of System.Exception, the behavior of .ToString has changed[1][2] and doesn't query anymore the `StackTrace` property overload of Java.Throwable which include Java stracktrace information.

As a result, the Java native stacktrace isn't displayed by default anymore when printing an exception or inspecting it under debugger.

[1]  https://github.com/mono/mono/blob/mono-4.4.0-branch/mcs/class/corlib/System/Exception.cs#L277
[2]  https://github.com/mono/mono/blob/master/mcs/class/referencesource/mscorlib/system/exception.cs#L489
Comment 2 Jonathan Pryor 2016-07-07 16:59:35 UTC
Fixed in monodroid/9ce53701.
Comment 3 Abhishek 2016-07-08 13:50:55 UTC
I have checked this issue and able to reproduce this issue at my end with following build: xamarin.android-6.1.99-342_0be581dc4ee4cdb9d06c8ffd0b7ad9b3cfd02d98.

screencast:
Application Output: https://gist.github.com/Abhishekk360/1718690825d8d3e1aac3edf315599371

To verify this issue I have checked this issue with latest master build provided in the trello card:
xamarin.android-6.1.99-373. 

I am unable to check the behavior due to this bug https://bugzilla.xamarin.com/show_bug.cgi?id=42425. Once this issue will be resolved I will verify this issue at my end.

Thanks!
Comment 4 Abhishek 2016-07-08 13:59:23 UTC
An Update to above issue I have missed to add the screencast: http://www.screencast.com/t/qWA3JOVUe

Thanks!
Comment 8 abhi 2016-07-18 12:36:03 UTC
As per comment 7 I am making this issue is verified fixed.

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.