Bug 42365 - Mono 4.4.1 OSX package doesn't clean up old symlinks from /usr/local/bin
Summary: Mono 4.4.1 OSX package doesn't clean up old symlinks from /usr/local/bin
Status: VERIFIED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: packaging (show other bugs)
Version: 4.4.0 (C7)
Hardware: PC Mac OS
: --- normal
Target Milestone: 4.8.0 (C9)
Assignee: Alexis Christoforides
URL:
Depends on:
Blocks:
 
Reported: 2016-07-05 19:12 UTC by Alexander Köplinger [MSFT]
Modified: 2017-01-10 15:46 UTC (History)
9 users (show)

Tags: C8SR1 potentialC8SR2
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Alexander Köplinger [MSFT] 2016-07-05 19:12:49 UTC
Since https://github.com/xamarin/bockbuild/commit/4bf7d2ee28d5fd1c6c9c4cb0231f0cef8a8ac859 we moved to using /etc/path.d for adding Mono to the PATH on OSX instead of putting the symlinks in /usr/local/bin.

However, the installer doesn't clean the old symlinks up. We should try to delete those in postinstall (with appropriate safeguard measures should Apple decide to further lock down /usr/local).
Comment 1 Luis Aguilera 2016-09-12 20:15:06 UTC
since C8 is now closed, and is shipping this week, I will move this but to the C8SR1 milestone. We'll continue working on the issue seeking it's resolution as soon as possible.
Comment 2 Alexis Christoforides 2016-12-19 14:48:43 UTC
Fixed in mono/bockbuild master and xamarin/bockbuild mono-4.8.0-branch.
Comment 3 Alexander Köplinger [MSFT] 2016-12-19 17:56:16 UTC
@Alexis I don't see a commit in mono/bockbuild master, did you forget to push?
Comment 4 Saurabh 2016-12-23 12:18:27 UTC
I have checked this with latest Cycle9 Mono 4.8.0.423 and observed that on location /etc/path.d I am seeing mono-commands and on location /usr/local/bin, I am not seeing any mono. This is the screencast for the same: https://www.screencast.com/t/3545W4RLSPb

Please let me know if there is anything else to verify this Issue?
Comment 5 Shruti 2017-01-10 08:21:58 UTC
@Alexander, It would be great help If you put your comments for Comment4. If the Saurabh Scenario to verify this issue is correct. Then I think we are good to change the status of this bug as Verified.
Comment 6 Alexander Köplinger [MSFT] 2017-01-10 15:46:42 UTC
@Shruti yes, it looks like this is working as intended in Mono 4.8. However I still don't see the relevant fix applied to the master branch in bockbuild.

I think it doesn't make sense to hold up verifying this bug for that though, I'll talk to Alexis separately. Changing status to Verified, thanks.