Bug 42341 - Page not removed from NavigationStack when hit Back quickly on iOS
Summary: Page not removed from NavigationStack when hit Back quickly on iOS
Status: RESOLVED DUPLICATE of bug 39908
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2016-07-04 10:13 UTC by John Hardman
Modified: 2016-08-10 16:11 UTC (History)
3 users (show)

Tags: Navigation animation back NavigationStack iOS
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 39908

Description John Hardman 2016-07-04 10:13:06 UTC
On iOS, using XF 2.3.0.49, if the user hits the Back button very quickly after initiating navigation to another page, the other page gets added to the NavigationStack but not removed again. This occurs when animation is being used in the Navigation.PushAsync call. I haven't reproduced it without animation, but that could just be because I'm too slow hitting the Back button when there is no animation.

So, the steps to reproduce are:
(1) Initiate an action that results in Navigation.PushAsync(page, true);
(2) The moment the new page starts appearing, hit the Back button
(3) The new page disappears and the original is shown again
(4) Check the NavigationStack - the page that is no longer visible is still on the stack.
Comment 1 Rui Marinho 2016-08-10 16:03:19 UTC
Can you try with 2.3.2-pre1 and see if the issue still exists.

Thanks
Comment 2 Rui Marinho 2016-08-10 16:11:32 UTC
Oh i didn't send my PR for this fix.. so never mind the last comment

*** This bug has been marked as a duplicate of bug 39908 ***