Bug 42301 - [WP] [UWP] Grid or ContentPage extends beyond screen bounds after certain navigation types.
Summary: [WP] [UWP] Grid or ContentPage extends beyond screen bounds after certain nav...
Status: RESOLVED DUPLICATE of bug 42055
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-07-01 07:20 UTC by Nathan Murphy
Modified: 2017-01-23 22:11 UTC (History)
5 users (show)

Tags: Windows ac
Is this bug a regression?: ---
Last known good build:


Attachments
Simple Reproduction App (1.73 KB, text/plain)
2016-07-01 07:20 UTC, Nathan Murphy
Details
Repro project (395.42 KB, application/x-zip-compressed)
2016-08-11 18:07 UTC, E.Z. Hart [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 42055

Description Nathan Murphy 2016-07-01 07:20:44 UTC
Created attachment 16541 [details]
Simple Reproduction App

On both Windows Phone 8.1 and Windows UWP (mobile only) when a new ContentPage is set via either manually setting App.Current.MainPage or by doing a Navigation.PushModalAsync, the new page doesn't render properly.

Either the new ContentPage extends beyond the bottom of the screen or the bottom row of a Grid contained within the ContentPage is positioned too low and is clipped at the bottom.

The size seems to be out by the same height as the phones top status bar.

If you navigate away from, and then back to the app, the screen redraws correctly upon returning.

Attached is a simple app that reproduces the error.
Comment 1 gilles.dehais 2016-07-08 15:57:21 UTC
I have the same issue with Grid and Layout.

https://bugzilla.xamarin.com/show_bug.cgi?id=42429

Plz fix this.
Comment 2 MarcinL 2016-08-03 10:53:46 UTC
Similar to https://bugzilla.xamarin.com/show_bug.cgi?id=42055
Comment 3 E.Z. Hart [MSFT] 2016-08-11 18:07:14 UTC
Created attachment 16994 [details]
Repro project
Comment 4 E.Z. Hart [MSFT] 2017-01-23 22:11:49 UTC

*** This bug has been marked as a duplicate of bug 42055 ***