Bug 4230 - DataContractJsonSerializer mishandles deserialization of null arrays
Summary: DataContractJsonSerializer mishandles deserialization of null arrays
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: BCL Class Libraries (show other bugs)
Version: 5.0
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Alexander Köplinger [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2012-04-04 10:34 UTC by Steve Gordon
Modified: 2015-10-30 20:17 UTC (History)
4 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Steve Gordon 2012-04-04 10:34:23 UTC
In porting existing .NET / Windows Phone code, I discovered a behavior of DataContractJsonSerializer in MonoTouch that is inconsistent with other platforms.

Specifically, when deserializing JSON where an array property has a null value, DataContractJsonSerializer incorrectly maps the null value to an empty array. This is problematic because it causes you to lose the ability to differentiate between null and empty.

For example, given the below class and JSON:

class:

public class Response
{
  public Notification[] Notifications
  {
    get;
    set;
  }
}

JSON:

{
  Notifications: null,
}

With MonoTouch, Notifications is set to Notification[0], whereas on other platforms, Notifications is correctly set to null.
Comment 1 Rodrigo Kumpera 2015-10-30 09:36:09 UTC
Hey Alex,

Could you look at this one?
Comment 2 Alexander Köplinger [MSFT] 2015-10-30 20:17:52 UTC
I confirmed it reproduces on Mono 4.0. It's fixed in Mono 4.2 because we moved to Reference Sources.

Curiously, while looking at it I was somewhat confused cause we still had a copy of DataContractJsonSerializer in System.ServiceModel.Web that's not used anymore. I opened https://github.com/mono/mono/pull/2185 to cleanup those and added the test from this bug while I was at it.

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.