Bug 42274 - System.IO.Compression.ZipArchive vs System.Xml.XmlReader
Summary: System.IO.Compression.ZipArchive vs System.Xml.XmlReader
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: General (show other bugs)
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: João Matos
URL:
Depends on:
Blocks:
 
Reported: 2016-06-30 11:43 UTC by RichardW
Modified: 2016-06-30 13:23 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description RichardW 2016-06-30 11:43:08 UTC
Related to 

https://github.com/OfficeDev/Open-XML-SDK/issues/64
https://bugzilla.xamarin.com/show_bug.cgi?id=39282


As described at: https://github.com/OfficeDev/Open-XML-SDK/issues/64#issuecomment-228791344

If you have a zip file which contains a single xml file and try to process it with the following code using Mono 4.4.0 then the operation completes, but on the current Master you get a System.NotSupportedException from System.IO.Compression.DeflateStream.get_Length().

public static void Main(string[] args)
{
    var fileStream = new FileStream("monoTest.zip", FileMode.Open, FileAccess.ReadWrite, FileShare.ReadWrite);
    var zipArchive = new ZipArchive(fileStream, ZipArchiveMode.Update);

    var firstStream = zipArchive.Entries[0].Open();

    var xmlReader = System.Xml.XmlReader.Create(firstStream);
}

Which looks to be because XmlReader is trying to query the length on the stream you give it, which fails because it's a DeflateStream whose length can't be queried.

This test successfully loads the XML data on MS.NET/Windows.
Comment 1 João Matos 2016-06-30 13:23:43 UTC
https://github.com/mono/mono/pull/3225

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 42274 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: