Bug 42248 - v4.4.1 & Logary: Invalid IL code in System.Configuration.ConfigurationManager:GetSection
Summary: v4.4.1 & Logary: Invalid IL code in System.Configuration.ConfigurationManager...
Status: RESOLVED INVALID
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 4.4.0 (C7)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-06-29 13:10 UTC by henrik
Modified: 2016-06-29 13:36 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description henrik 2016-06-29 13:10:42 UTC
Unhandled Exception:
System.InvalidProgramException: Invalid IL code in System.Configuration.ConfigurationManager:GetSection (string): IL_0000: ret


  at System.Configuration.PrivilegedConfigurationManager.GetSection (System.String sectionName) <0x26cb8b0 + 0x00013> in <filename unknown>:0
  at System.Diagnostics.DiagnosticsConfiguration.GetConfigSection () <0x26cb858 + 0x00013> in <filename unknown>:0
  at System.Diagnostics.DiagnosticsConfiguration.Initialize () <0x26cb720 + 0x0008b> in <filename unknown>:0
  at System.Diagnostics.DiagnosticsConfiguration.get_IndentSize () <0x26cb6a0 + 0x0000b> in <filename unknown>:0
  at System.Diagnostics.TraceInternal.InitializeSettings () <0x26cb4d0 + 0x000bf> in <filename unknown>:0
  at System.Diagnostics.TraceInternal.get_UseGlobalLock () <0x26cb4a8 + 0x0000b> in <filename unknown>:0
  at System.Diagnostics.TraceInternal.Write (System.String message) <0x26cae00 + 0x00043> in <filename unknown>:0
  at System.Diagnostics.Trace.Write (System.String message) <0x26cad90 + 0x00013> in <filename unknown>:0
  at Fuchu.Helpers+tprintf@38.Invoke (System.String s) <0x26cad50 + 0x00013> in <filename unknown>:0
  at Microsoft.FSharp.Core.PrintfImpl+StringPrintfEnv`1[TResult].Finalize () <0x26226b8 + 0x00030> in <filename unknown>:0
  at Microsoft.FSharp.Core.PrintfImpl+Final1@224[TState,TResidue,TResult,A].Invoke (Microsoft.FSharp.Core.FSharpFunc`2 env, A a) <0x26cac98 + 0x00085> in <filename unknown>:0
  at Microsoft.FSharp.Core.OptimizedClosures+Invoke@3253[T2,TResult,T1].Invoke (T2 u) <0x7a36b0 + 0x00024> in <filename unknown>:0
  at Fuchu.Impl.runEval[a] (Microsoft.FSharp.Core.FSharpFunc`2 eval, Fuchu.Test tests) <0x7a2e48 + 0x0013f> in <filename unknown>:0
  at Fuchu.Tests.Run (Fuchu.Test tests) <0x7a2e18 + 0x0001f> in <filename unknown>:0
  at Fuchu.Tests+DefaultMainWithOptions@479-1.Invoke (Fuchu.Test tests) <0x7a2df0 + 0x00013> in <filename unknown>:0
  at Fuchu.Tests.DefaultMainWithOptions (Fuchu.Test tests, Fuchu.RunOptions options) <0x7a2d90 + 0x00050> in <filename unknown>:0
  at Fuchu.Tests.DefaultMainThisAssembly (System.String[] args) <0x52b850 + 0x00106> in <filename unknown>:0
Comment 1 henrik 2016-06-29 13:13:09 UTC
Works on Linux. Not on OS X.
Comment 2 henrik 2016-06-29 13:13:18 UTC
Linux build that works: https://travis-ci.org/logary/logary/jobs/141070733
Comment 3 Alexander Köplinger [MSFT] 2016-06-29 13:36:28 UTC
I can confirm the behavior on OSX here with Mono 4.4.1 and 4.4.0.182.

I checked the project and you're somehow copying the reference assemblies from the -api folders (http://www.mono-project.com/docs/about-mono/releases/4.4.0/#class-libraries) into your app directory. This doesn't work as they only contain metadata, no actual method IL.

Looks like this is not an issue in Mono, so I'm closing this for now.