Bug 42239 - Cannot use single-character DU case sub-label names
Summary: Cannot use single-character DU case sub-label names
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: F# Add-in (show other bugs)
Version: 6.1.0 (C8)
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Jason Imison
URL:
: 42432 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-29 11:37 UTC by henrik
Modified: 2016-09-20 08:25 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
It's ffed up (14.51 KB, image/png)
2016-06-29 11:37 UTC, henrik
Details
Intellisense settings (29.49 KB, image/png)
2016-07-01 09:04 UTC, Jason Imison
Details
it's settled: no setting set in settings (129.32 KB, image/png)
2016-07-01 09:09 UTC, henrik
Details
Another sample – code completion in comment (113.36 KB, image/png)
2016-07-01 12:51 UTC, henrik
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description henrik 2016-06-29 11:37:00 UTC
Created attachment 16519 [details]
It's ffed up

With code like this:

type A = A of a:int

You'll get this series of interactions:

TYPE 'type '
SHOW 'type '
TYPE 'A'
SHOW 'type AA' (note the extra A)
TICK TIME 1 second
SHOW 'type A'
TYPE '='
SHOW 'type A  =' (note the two spaces)
TYPE 'A of '
SHOW 'type A  = A of '
TYPE 'a'
SHOW 'type A  = A of aa' (doubles the character)
TYPE ' ' (to put a space between the case name label and its type)
SHOW 'type A  = A of AA ' (editor snags on the code completion and chooses A when SPACE is pressed, then the bug doubles the character in the editor)
TICK TIME 1 second
SHOW 'type A  = A of A ' (is hidden again)
TYPE ':'
SHOW 'type A  = A of AA :' (is shown again, this time for a long period of time)

and so on. It's broken to say the least.

Expected behaviour 1:

Code-completion doesn't stop you from typing what you want to type; remove space as a 'selector' for a chosen element in the list in the editor.

Expected behaviour 2:

No duplicated characters.

Trying to fix the issue in the editor leads to the attached state.
Comment 1 Jason Imison 2016-07-01 09:04:01 UTC
Created attachment 16543 [details]
Intellisense settings

Try changing these settings for the intellisense issue.

Thanks for the detailed report. This looks like a bug with the new syntax highlighting regexes :( I thought I'd fixed all the cases (there were a ton of similar issues during dev) but looks like at least one remains.
Comment 2 henrik 2016-07-01 09:08:33 UTC
That setting doesn't exist for me.
Comment 3 henrik 2016-07-01 09:09:13 UTC
Created attachment 16544 [details]
it's settled: no setting set in settings
Comment 4 Jason Imison 2016-07-01 09:11:25 UTC
Ah, only the first setting is there (that triggers aggressive intellisense). The 2nd setting (for selecting completions when you press space) must have been added some time in 6.1
Comment 5 henrik 2016-07-01 12:51:17 UTC
Created attachment 16547 [details]
Another sample – code completion in comment
Comment 6 Jason Imison 2016-07-01 12:52:44 UTC
Thanks, will take a look
Comment 7 xamarin-release-manager 2016-07-04 10:46:31 UTC
Fixed in version 6.1.0.5058 (fix-42239)

Author: nosami
Commit: f1312357134f43b7a08d35ceebabdfdcb1f5a675 (mono/monodevelop)
Comment 8 xamarin-release-manager 2016-07-06 18:42:37 UTC
Fixed in version 6.0.2.47 (cycle7)

Author: nosami
Commit: 65bcda7bd4f70b2659ff92b337348ca8d323f837 (fsharp/xamarin-monodevelop-fsharp-addin)
Included in Commit: 967c5db7b536dbf837cdec660ac670987da73474 (mono/monodevelop)
Comment 9 xamarin-release-manager 2016-07-08 15:41:27 UTC
Fixed in version 6.0.2.56 (cycle7)

Author: nosami
Commit: 65bcda7bd4f70b2659ff92b337348ca8d323f837 (fsharp/xamarin-monodevelop-fsharp-addin)
Included in Commit: 196de578deae85581a1ad509183a6df135a35230 (mono/monodevelop)
Comment 10 xamarin-release-manager 2016-07-08 19:17:11 UTC
Fixed in version 6.1.0.5121 (cycle8)

Author: nosami
Commit: 249c3b5848bbad26e2297fdbe198bdf746c9fa37 (mono/monodevelop)
Comment 11 Jason Imison 2016-07-11 16:56:54 UTC
*** Bug 42432 has been marked as a duplicate of this bug. ***