Bug 42206 - Incorrectly detecting xamarin forms xaml
Summary: Incorrectly detecting xamarin forms xaml
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Xamarin.Forms Previewer (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: Highest blocker
Target Milestone: (C8)
Assignee: Alan McGovern
URL:
: 42233 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-28 13:34 UTC by Alan McGovern
Modified: 2016-07-05 05:14 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Alan McGovern 2016-06-28 13:34:46 UTC
The xaml previewer is being enabled for WPF xaml files, for example this file:

<UserControl x:Class="MonoTouch.Design.Client.Windows.MethodListPanel"
             xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
             xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
             xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006" 
             xmlns:d="http://schemas.microsoft.com/expression/blend/2008" 
             mc:Ignorable="d"
			 xmlns:local="clr-namespace:MonoTouch.Design.Client.Windows"
             d:DesignHeight="300" d:DesignWidth="300" Name="methodListPanel">
	<UserControl.Resources>
Comment 1 Alan McGovern 2016-06-29 10:03:53 UTC
*** Bug 42233 has been marked as a duplicate of this bug. ***
Comment 2 xamarin-release-manager 2016-07-01 11:35:40 UTC
Fixed in version 6.1.0.5096 (master)

Author: Alan McGovern
Commit: 7cd650560d8e98b45be702cff07168bd3520604a (xamarin/md-addins)
Included in Commit: 964f8b4344468429a2b50a4476e163d2c6b1ac72 (mono/monodevelop)
Comment 4 Alan McGovern 2016-07-04 12:25:05 UTC
I'm not 100% sure what you're doing in that screencast.

The fix we made was that if you double click on a xaml file in the property panel, or open it in any other way, we check it is a xamarin.forms xaml file before enabling the previewer.

If the file is xamarin.forms xaml originally and then you modify it to make it invalid, then it will simply be invalid xaml and will display the error you saw.

Note You need to log in before you can comment on or make changes to this bug.