Bug 42193 - Redirecting standard output on nuget causes endless stream of spaces
Summary: Redirecting standard output on nuget causes endless stream of spaces
Status: CONFIRMED
Alias: None
Product: Class Libraries
Classification: Mono
Component: General (show other bugs)
Version: 4.4.0 (C7)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-06-27 15:38 UTC by Alexander Köplinger [MSFT]
Modified: 2017-10-18 09:43 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 42193 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Alexander Köplinger [MSFT] 2016-06-27 15:38:15 UTC
I ran into this while helping Rolf diagnose some nuget feed issues in the macios build.

If you redirect stdout of nuget, then it basically never finishes and writes an endless stream of 12spaces+linefeed.

Repro: Run "nuget help > test.log"

It seems to happen on all nuget commands, except (interestingly) on "nuget restore".

Similar report on the nuget bug tracker: https://github.com/NuGet/Home/issues/2029

I'm not 100% sure if it's a nuget or Mono problem, but given that redirecting stdout works on Windows it's likely the latter.

Environment:
OSX 10.11
Mono 4.4.1
NuGet 2.8.5