This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 42100 - [UWP] Default Button Color is set to Transparent
Summary: [UWP] Default Button Color is set to Transparent
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 2.3.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 45302 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-23 09:22 UTC by Anubhav Ranjan
Modified: 2016-11-29 11:27 UTC (History)
7 users (show)

See Also:
Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments

Description Anubhav Ranjan 2016-06-23 09:22:55 UTC
The background color of Button in a UWP App generated on using Xamarin.Forms is currently overriding the Background Color by default to set it to #00000000. However, the actual Button Color is found to be #33000000
https://dl.dropboxusercontent.com/u/30949500/Xamarin%20Samples/354638/UWP%20Button%20Property.PNG

#Screenshots:
===========
Xamarin.Forms UWP: https://dl.dropboxusercontent.com/u/30949500/Xamarin%20Samples/354638/Screenshot%20%2839%29.png

UWP: https://dl.dropboxusercontent.com/u/30949500/Xamarin%20Samples/354638/Screenshot%20%2838%29.png


#Sample:
========
https://dl.dropboxusercontent.com/u/30949500/Xamarin%20Samples/354638/XamarinTest.zip

#Steps to Reproduce:
===============
Xamarin.Forms UWP: 
 - Set UWP Project as the Startup project
 - Run the App

UWP:
 - Open App.xaml.cs inside UWP Project
 - Goto Line 78
 - Update typeof(MainPage) to typeof(TestPage)
 - Run the App

#Version Info:
=========
Microsoft Visual Studio Enterprise 2015
Version 14.0.25123.00 Update 2
Microsoft .NET Framework
Version 4.6.01038

Installed Version: Enterprise

Architecture and Modeling Tools   00322-80000-00000-AA004
Microsoft Architecture and Modeling Tools
    
UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

Visual Basic 2015   00322-80000-00000-AA004
Microsoft Visual Basic 2015

Visual C# 2015   00322-80000-00000-AA004
Microsoft Visual C# 2015

Visual C++ 2015   00322-80000-00000-AA004
Microsoft Visual C++ 2015

Windows Phone SDK 8.0 - ENU   00322-80000-00000-AA004
Windows Phone SDK 8.0 - ENU

Application Insights Tools for Visual Studio Package   5.209.60613.1
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2015.1   14.1.20512.0
ASP.NET and Web Tools 2015.1

ASP.NET Web Frameworks and Tools 2012.2   4.1.41102.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.40314.0
For additional information, visit http://www.asp.net/

Azure App Service Tools v2.8.1   14.0.11123.0
Azure App Service Tools v2.8.1

Common Azure Tools   1.7
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

JetBrains ReSharper Ultimate 10.0.2   Build 104.0.20151218.120627
JetBrains ReSharper Ultimate package for Microsoft Visual Studio. For more information about ReSharper Ultimate, visit http://www.jetbrains.com/resharper. Copyright © 2016 JetBrains, Inc.

KofePackagePackage Extension   1.0
KofePackagePackage Visual Studio Extension Detailed Info

Microsoft .NET Core Tools (Preview 1)   14.1.20512.0
Microsoft .NET Core Tools (Preview 1)

Microsoft Azure Mobile Services Tools   1.4
Microsoft Azure Mobile Services Tools

Microsoft MI-Based Debugger   1.0
Provides support for connecting Visual Studio to MI compatible debuggers

NuGet Package Manager   3.4.4
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   14.0.60311.1
Microsoft SQL Server Data Tools

TypeScript   1.8.31.0
TypeScript tools for Visual Studio

Visual Studio 2015 Tools for Docker - Preview   0.21
The Visual Studio 2015 Tools for Docker Preview enables developers to edit and refresh an ASP .NET 5 Web Application running in a Docker container and to publish an ASP .NET 5 Web or Console application to a Docker container running on a Linux or Windows Virtual Machine on Azure.

Visual Studio Tools for Universal Windows Apps   14.0.25219.00
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

Xamarin   4.2.0.21 (a532c82)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   6.1.99.224 (804c6cb)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   9.9.0.719 (3afb4af)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 2 Samantha Houts 2016-10-20 20:42:38 UTC
*** Bug 45302 has been marked as a duplicate of this bug. ***
Comment 3 Stephane Delcroix 2016-11-08 15:42:17 UTC
The fix for this issue has been merged into our master, and will be released in 2.3.4-pre1
Comment 4 Parmendra Kumar 2016-11-29 11:27:25 UTC
I have checked this issue with xamarin.forms 2.3.4-pre1 and its working fine.


Hence closing this issue.

Note You need to log in before you can comment on or make changes to this bug.