Bug 42090 - Ambiguous Reference Errors in Xamarin.Forms that break Intellisense in Text Editor
Summary: Ambiguous Reference Errors in Xamarin.Forms that break Intellisense in Text E...
Status: RESOLVED DUPLICATE of bug 41572
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor (show other bugs)
Version: 6.0.0 (C7)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2016-06-22 18:50 UTC by ahmed
Modified: 2016-07-12 08:33 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 41572

Description ahmed 2016-06-22 18:50:24 UTC
Similar to Bug 41928 & 41572 https://bugzilla.xamarin.com/show_bug.cgi?id=41928

However those bugs are supposed to be resolved in 6.0.1.5023 but I am still seeing this issue in stable release: 6.0.1.8

Attempting to edit any XAML.CS code file in my project brings up red, errors on variables and items 

See this SO POST http://stackoverflow.com/questions/37709923/ambiguous-reference-inline-error-in-xamarin-forms


Started a new Xamarin.Forms project. My view (aptly named MyView) has a ListView in it, with a reference of x:Name=“myListView”.

When trying to access it from the code-behind, I’m getting an inline error

“Error: Ambiguity between MyView.myListView and MyView.myListView”,


My VERSION INFO

=== Xamarin Studio Enterprise ===

Version 6.0.1 (build 8)
Installation UUID: 463fa42e-692d-4ad1-a5d6-90e892a9f779
Runtime:
	Mono 4.4.1 (mono-4.4.0-branch-c7sr0/4747417) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404010000

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Version: 6.1.1.1 (Xamarin Enterprise)
Android SDK: /Users/ahmedkhan/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.8.0_77"
Java(TM) SE Runtime Environment (build 1.8.0_77-b03)
Java HotSpot(TM) 64-Bit Server VM (build 25.77-b03, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 7.3.1 (10188.1)
Build 7D1014

=== Xamarin.Mac ===

Not Installed

=== Xamarin.iOS ===

Version: 9.8.1.4 (Xamarin Enterprise)
Hash: 3cf8aae
Branch: c7sr0
Build date: 2016-06-20 16:09:58-0400

=== Build Information ===

Release ID: 600010008
Git revision: 0ecc3639cde21616d675e4fdef1b858d166dd065
Build date: 2016-06-20 13:16:51-04
Xamarin addins: a9252e6df4851fbbed1f9c6228e7b6dd1b475ac5
Build lane: monodevelop-lion-cycle7-sr0

=== Operating System ===

Mac OS X 10.11.2
Darwin Ahmeds-MacBook-Pro.local 15.2.0 Darwin Kernel Version 15.2.0
    Fri Nov 13 19:56:56 PST 2015
    root:xnu-3248.20.55~2/RELEASE_X86_64 x86_64
Comment 2 ahmed 2016-06-27 20:36:39 UTC
this is in the PCL project - I did update to Alpha last week and did not see a resolution of the issue and downgraded back to stable.. I can try the next stable release
Comment 3 David Karlaš 2016-07-12 08:33:05 UTC
This is duplicate

*** This bug has been marked as a duplicate of bug 41572 ***