Bug 42089 - Addins for Xamarin Studio 6.0 are shown as incompatible with Xamarin Studio 6.0.1
Summary: Addins for Xamarin Studio 6.0 are shown as incompatible with Xamarin Studio 6...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Add-ins (show other bugs)
Version: 6.0.0 (C7)
Hardware: PC Mac OS
: Normal normal
Target Milestone: C7SR1
Assignee: Lluis Sanchez
URL:
: 42119 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-22 18:43 UTC by Matt Ward
Modified: 2016-06-24 16:40 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Matt Ward 2016-06-22 18:43:04 UTC
To repro:

1) With Xamarin Studio 6.0 installed add some third party addins such as:

DNX
Addin maker
VSCodeDebugger.

2) Upgrade Xamarin Studio from 6.0 to 6.0.1
3) Open the Add-in Manager.

Expected result:

DNX, Addin maker and VSCodeDebugger addins are enabled.

Actual result:

All these adds are shown as not being loaded.
Error message: 

This add-in can't be loaded due to missing dependencies. 
The following dependencies required by this add-in are not available:
Required: MonoDevelop.Core v6.0, found v6.0.1
Required: MonoDevelop.Ide v6.0, found v6.0.1
Comment 1 Lluis Sanchez 2016-06-22 19:56:17 UTC
Fixed in 6.0.2
Comment 2 Matt Ward 2016-06-24 10:22:18 UTC
*** Bug 42119 has been marked as a duplicate of this bug. ***
Comment 3 Kyle White 2016-06-24 16:29:09 UTC
Verified this is resolved in version 6.0.1.9 built from lane 'monodevelop-lion-cycle7-sr0' to be delivered as a stable hotfix. 

https://gist.github.com/anonymous/84a57ffb51494480156c46680bb25d8f
Comment 4 Mohit Kheterpal 2016-06-24 16:40:23 UTC
I have checked this issue and observed that this issue has been fixed with XamarinStudio-6.0.1.9_e879ce52093257c5c386ad7e390dfaa937fa7f90 

Screencast : http://www.screencast.com/t/6og48I9wm

Hence closing this issue by marking it as Verified.

Thanks