Bug 42058 - crash after upgrading mono to 4.4.0
Summary: crash after upgrading mono to 4.4.0
Status: RESOLVED DUPLICATE of bug 42169
Alias: None
Product: Runtime
Classification: Mono
Component: Interop (show other bugs)
Version: 4.4.0 (C7)
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-06-22 03:38 UTC by webmaster
Modified: 2016-07-04 19:38 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description webmaster 2016-06-22 03:38:24 UTC
Our services on ubuntu 14.04 runs well before the upgrading (and it continue to be so after the upgrading for a while). But today, it starts to crash on starting up:

```
Error: No managed allocator, but we need one for AOT.
Are you using non-standard GC options?

Stacktrace:

  at <unknown> <0xffffffff>
  at System.__Filters..cctor () <0x00014>
  at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <0x00062>
  at <unknown> <0xffffffff>
  at ClrFuncReflectionWrap.Create (System.Reflection.Assembly,string,string) <0x0003b>
  at MonoEmbedding.GetFunc (string,string,string) <0x00033>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_object_object_object_object (object,intptr,intptr,intptr) <0x00071>

Native stacktrace:

	/usr/lib/libmonosgen-2.0.so.1(+0xdac0d) [0x7f6922b7dc0d]
	/lib/x86_64-linux-gnu/libpthread.so.0(+0x10330) [0x7f692563f330]
	/lib/x86_64-linux-gnu/libc.so.6(gsignal+0x37) [0x7f69252a0c37]
	/lib/x86_64-linux-gnu/libc.so.6(abort+0x148) [0x7f69252a4028]
	/usr/lib/libmonosgen-2.0.so.1(+0x26c189) [0x7f6922d0f189]
	/usr/lib/libmonosgen-2.0.so.1(+0x26c397) [0x7f6922d0f397]
	/usr/lib/libmonosgen-2.0.so.1(+0x26c442) [0x7f6922d0f442]
	/usr/lib/libmonosgen-2.0.so.1(+0xc6170) [0x7f6922b69170]
	/usr/lib/libmonosgen-2.0.so.1(+0xc91f4) [0x7f6922b6c1f4]
	/usr/lib/libmonosgen-2.0.so.1(+0xcfefb) [0x7f6922b72efb]
	/usr/lib/libmonosgen-2.0.so.1(+0xdccdd) [0x7f6922b7fcdd]
	[0x40de4c15]

Debug info from gdb:


=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Aborted (core dumped)

```

The service uses edgejs to interop between nodejs and mono, by the way
Comment 1 Alexander Köplinger [MSFT] 2016-07-04 19:38:24 UTC
Thanks, this is most certainly a duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=42169

*** This bug has been marked as a duplicate of bug 42169 ***

Note You need to log in before you can comment on or make changes to this bug.