Bug 42055 - [UWP][WinRT] ScrollView/ListView Bottom Cut Off in a Modal Page
Summary: [UWP][WinRT] ScrollView/ListView Bottom Cut Off in a Modal Page
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 2.3.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 42301 53848 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-21 23:04 UTC by Jimmy [MSFT]
Modified: 2017-03-23 13:32 UTC (History)
7 users (show)

Tags: Windows ac
Is this bug a regression?: ---
Last known good build:


Attachments
repro solution (845.47 KB, application/zip)
2016-06-21 23:04 UTC, Jimmy [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jimmy [MSFT] 2016-06-21 23:04:37 UTC
Created attachment 16432 [details]
repro solution

### Overview
The bottom of a ListView/ScrollView appears off screen on UWP and WinRT apps running on a mobile device when the page is pushed modally.


### Steps to Reproduce
1. Run the UWP or WinRT project in the attached repro solution
2. Press "Push Modally"
3. Scroll to the bottom of the list


### Expected Results
You will see "Item 29" at the end of the list. Pressing "Next Page" in #2 of the repro steps demonstrates the expected result.


### Actual Results
"Item 29" appears cutoff at the bottom of the screen, but you are not able to scroll any further.


### Testing Info
Tested using Forms 2.3.0.49
Comment 1 MarcinL 2016-08-03 08:30:08 UTC
Any new info on this issue? I've got modals with buttons positioned on bottom of screen which gets cut off by phone soft buttons.
Comment 2 MarcinL 2016-08-03 08:36:43 UTC
Even setting 
            ApplicationView.GetForCurrentView().SetDesiredBoundsMode(ApplicationViewBoundsMode.UseVisible);

in both UWP and WinPhone App.xaml.cs makes no difference to modals while preventing soft buttons from overlaping normal pages.
Comment 3 Rui Marinho 2016-12-17 01:12:29 UTC
Should be fixed in 2.3.4-pre2
Comment 4 E.Z. Hart [MSFT] 2017-01-23 22:11:49 UTC
*** Bug 42301 has been marked as a duplicate of this bug. ***
Comment 5 Novak Savic 2017-03-23 13:32:01 UTC
*** Bug 53848 has been marked as a duplicate of this bug. ***