Bug 42052 - Deployment fails with "internal error: missing , in ID_SEND" for Android N devices and emulators using the current Stable channel (Cycle 7)
Summary: Deployment fails with "internal error: missing , in ID_SEND" for Android N de...
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 6.1.0 (C7)
Hardware: PC All
: --- normal
Target Milestone: 6.1.x (C7SR1)
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2016-06-21 22:04 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2016-07-22 15:37 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: No
Last known good build:


Attachments

Description Brendan Zagaeski (Xamarin Team, assistant) 2016-06-21 22:04:27 UTC
Deployment fails with "internal error: missing , in ID_SEND" for Android N devices and emulators using the current Stable channel (Cycle 7)


I am filing this bug to provide a place to tally the number of users who might be looking to use Android N devices and emulators on the Stable channel.  These would be users who do _not_ need the Android N API bindings but who wish to use an Android N device during development with the current Stable channel (Cycle 7) versions.

**Users who wish to add themselves to the tally**: please add yourself on CC on this bug report.




## Current recommended approach to deploy to Android N devices

Install the Android N "web preview" version:

https://releases.xamarin.com/preview-android-n-support-preview-2/




## Example steps to replicate

1. Set up an Android N (API 24) emulator using the Android Virtual Device (AVD) manager.

2. Create a new "Android > App > Android App" project in Xamarin Studio.

3. Attempt to deploy the app to the Android N emulator (for example via "Run > Start Debugging").

You can also hit the error by running the `Install` target from the command line similar to:
xbuild /t:Install AndroidApp1.csproj




## Results


### Output from the "Deploying to Device" pad (excerpt)

> Deployment failed because of an internal error: missing , in ID_SEND


### Output from `xbuild /t:Install` (excerpt)

> Installing the Mono shared runtime (debug - 1466176850)...
> :Deployment failed
> Mono.AndroidTools.AdbException: missing , in ID_SEND
>   at Mono.AndroidTools.Util.AggregateAsyncResult.CheckError (CancellationToken token) <0x65f9b00 + 0x00053> in <filename unknown>:0 
>   at Mono.AndroidTools.Adb.AdbSyncClient.EndPush (IAsyncResult result) <0x7de6e08 + 0x00047> in <filename unknown>:0 
>   at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (IAsyncResult iar, System.Func`2 endFunction, System.Action`1 endAction, System.Threading.Tasks.Task`1 promise, Boolean requiresSynchronization) <0x7de6b60 + 0x00067> in <filename unknown>:0
Comment 1 Chris Waldron 2016-06-27 22:42:53 UTC
I'm receiving the same error once the emulator is running.

When the emulator is not running I'm receiving the following messages:

Detecting installed packages

Removing old runtime

Installing shared runtime

Deployment failed because of an internal error: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.

Deployment failed. Internal error.


***
When the emulator is running I get the following messages:

Detecting installed packages

Removing old runtime

Installing shared runtime

Deployment failed because of an internal error: missing , in ID_SEND

Deployment failed. Internal error.
Comment 2 Chris Waldron 2016-06-27 22:48:24 UTC
This is for API 24.  It works for API 23.
Comment 3 Jonathan Pryor 2016-07-01 03:19:28 UTC
This was fixed in androidtools/8ab5b3e6 and monodroid/46b92cc8.

We'll need to ensure that the IDEs are also updated to an appropriate androidtools version.
Comment 6 Brendan Zagaeski (Xamarin Team, assistant) 2016-07-05 18:10:29 UTC
## For any additional users who come across this bug

As a small follow-up to Comment 3, note that the instruction from Comment 0 is still applicable:


**Users who wish to add themselves to the tally**: please add yourself on CC on this bug report.



So any new users who wish to tally yourselves on this bug, please do continue to add yourselves to the CC list.  Thanks!
Comment 8 Jonathan Pryor 2016-07-11 14:52:50 UTC
Fixed in androidtools/cycle7/c504d9b and monodroid/cycle7/a509264.
Comment 9 Gerry 2016-07-21 12:34:16 UTC
Jon--your comment implies to me this was fixed in cycle7?

I'm on the beta channel running Cycle 7 (XA 6.1.2.16, XS 6.0.2 (build 69)) and still seeing this issue.

My device is a Nexus 6 running Android 7 NPD90G (Preview 5). Can you clarify where/how we'd see this fix?

Thanks,
Gerry
Comment 10 Jonathan Pryor 2016-07-21 19:41:13 UTC
@Gerry: Are you installing via the IDE? Could you try installing from the command-line?

> msbuild /t:Install YourProject.csproj

Use `xbuild` on OS X.
Comment 11 Gerry 2016-07-22 04:07:34 UTC
Jon--yes, that worked from the command line (used build as I'm on macOS). So that is good news. It will save me some time as I've been creating the package and copying to dropbox and then installing from the phone.

However, I'm hoping to debug as I have an issue that only occurs on Android N. Any options to be able to do that?

Thanks,
Gerry
Comment 12 Jonathan Pryor 2016-07-22 15:37:53 UTC
> that worked from the command line

This means that the fix hasn't been applied to the IDEs yet. Xamarin.Android 6.1.2 isn't yet stable, so this may get fixed before promotion to stable.

> I'm hoping to debug as I have an issue that only occurs on Android N

I believe you can debug even if Fast Deployment is disabled. This would be terrible around the debug/develop/deploy cycle, but it should allow you to Debug within the IDE...

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 42052 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: