Bug 42040 - Xamarin.Forms solution does not deploy until android setting are re-set
Summary: Xamarin.Forms solution does not deploy until android setting are re-set
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler (show other bugs)
Version: unspecified
Hardware: PC Windows
: High major
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2016-06-21 17:40 UTC by Reader Man
Modified: 2017-10-04 16:12 UTC (History)
5 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Android Settings (23.63 KB, image/png)
2016-06-21 17:40 UTC, Reader Man
Details

Description Reader Man 2016-06-21 17:40:15 UTC
Created attachment 16421 [details]
Android Settings

# Steps to Reproduce:

I have this solution, that does not deploy in debug mode in android till I go to the .Droid project, and selecting its properties, then go to:
Android Options\Packaging Tab\
then un-tick both [Use shared Run-time] + [Use Fast Deployment (debug mode only)]
Save the changes.
then immediately tick both of them back on.
the problem, is that you need to do that every time you are going to debug and deploy the app in android emulator, or it will not deploy it.




# Expected Behavior:

It should deploy the app in debug, without the need for resetting the project settings.

Actual Behavior:

It will not deploy, unless I reset the droid project settings as stated above.


# The sample solution here:

https://drive.google.com/open?id=0B2xC75mde6w0UHlybk9DX2g0Z1E


# Environment:

HDD: Samsung SSD 850 Pro 256GB
CPU: i7-2600 3.4GHz
RAM: 16GB
OS: win 10
IDE: VS 2015 update 2 + VS 2015 update 2 cumulative update: vs14-kb3151378.exe
Add-Ons: There is NO, I repeat no plug-ins like resharper or refactor installed, only plain VS, and even if they are, the loading of a solution having 55 normal class library projects, is faster than a solution having 55 PCL projects.
Xamarin: installed 4.1.0.530
Solution using Xamarin.Forms nuget 2.3.0.49

# Needed installations:

* Syncfusion Essential Studio 2016 Vol 1 Xamarin u1 --> community edition: https://www.syncfusion.com/products/whatsnew
* sqlite-uwp-3130000.vsix: https://www.sqlite.org/2016/sqlite-uwp-3130000.vsix
* Visual Studio Emulator for Android 2.2: https://www.visualstudio.com/en-us/features/msft-android-emulator-vs.aspx


This was also written here:
https://github.com/dotnet/roslyn/issues/12132

as i don't know if this should be reported to Xamarin or Microsoft.
Comment 1 Reader Man 2016-06-22 01:03:50 UTC
**The Working Startup projects are only**:
testSyncfusion.Droid
testSyncfusion.UWP
And i am experiencing the problems with the testSyncfusion.Droid project.
Comment 2 dean.ellis 2017-02-23 09:25:49 UTC
Hi 

Are you able to get us the diagnostic build output from the first build and deploy? You will need to get the output from the Build and Deploy Tabs in the Output Window.

Also after creating the project does the app deploy using

msbuild <project> /t:SignAndroidPackage /v:d 
msbuild <project> /t:Install /v:d 

This will deploy the app from the command line.
Comment 3 Jon Douglas [MSFT] 2017-10-04 16:12:17 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!

Note You need to log in before you can comment on or make changes to this bug.