Bug 42032 - UINavigationBar.Appearance.BarTintColor changes Tab bar color
Summary: UINavigationBar.Appearance.BarTintColor changes Tab bar color
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.3.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 42098 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-21 13:52 UTC by John Miller [MSFT]
Modified: 2016-06-28 11:39 UTC (History)
5 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project (29.57 KB, application/zip)
2016-06-21 13:52 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Miller [MSFT] 2016-06-21 13:52:31 UTC
Created attachment 16420 [details]
Sample Project

**Overview:**

   After updating to 2.3, UINavigationBar.Appearance.BarTintColor started changing the TabbedPage tab bar at the bottom. 

**Steps to Reproduce:**

   1. Run the attached sample on iOS

**Actual Results:**

   The navigation bar and tab bar are red.

**Expected Results:**

   Only the navigation bar should be red.

**Build Date & Platform:**

   XF 2.3

**Additional Information:**

   XF 2.2 works as expected.
   This looks like there problem area: https://github.com/xamarin/Xamarin.Forms/blob/2.3.0/Xamarin.Forms.Platform.iOS/Renderers/TabbedRenderer.cs#L311-L315
Comment 1 Samantha Houts [MSFT] 2016-06-24 16:51:18 UTC
*** Bug 42098 has been marked as a duplicate of this bug. ***
Comment 2 Rui Marinho 2016-06-28 11:39:46 UTC
Hi, this issue should be fixed in the 2.3.0 hotfix to be released and next versions of Xamarin.Forms.