Bug 41955 - Bitcode "missing image did not probe corlib" exception thrown
Summary: Bitcode "missing image did not probe corlib" exception thrown
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: JIT (show other bugs)
Version: 4.5.X
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Alexander Kyte
URL:
Depends on:
Blocks:
 
Reported: 2016-06-17 18:35 UTC by Alexander Kyte
Modified: 2016-07-01 01:22 UTC (History)
3 users (show)

See Also:
Tags: bitcode_mobile_static
Is this bug a regression?: ---
Last known good build:


Attachments

Description Alexander Kyte 2016-06-17 18:35:25 UTC
The test bug-30085.exe throws the exception "Missing image did not probe corlib" because System.Type.GetType does not correctly
return a type for 

System.Nullable`1[[System.IO.Pipes.PipeOptions, System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]
Comment 1 Zoltan Varga 2016-07-01 01:22:03 UTC
Should be fixed in master.

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.