Bug 41913 - [Roslyn] HashSet allocation crash?
Summary: [Roslyn] HashSet allocation crash?
Status: RESOLVED DUPLICATE of bug 39832
Alias: None
Product: Runtime
Classification: Mono
Component: GC (show other bugs)
Version: 4.4.0 (C7)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-06-16 20:42 UTC by Stephen Shaw
Modified: 2016-06-17 09:43 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 39832

Description Stephen Shaw 2016-06-16 20:42:06 UTC
Full stacktrace: https://gist.github.com/decriptor/bb1cc1243f5ea9686823b7b11b156b56

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) object.__icall_wrapper_mono_gc_alloc_vector (intptr,intptr,intptr) <IL 0x00009, 0x00065>
  at (wrapper alloc) object.AllocVector (intptr,intptr) <IL 0x00096, 0x0013c>
  at System.Collections.Generic.HashSet`1<T_REF>.SetCapacity (int,bool) [0x00000] in /private/tmp/source-mono-4.4.0-c7-baseline/bockbuild-mono-4.4.0-c7-baseline/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/System.Core/System/Collections/Generic/HashSet.cs:929
  at System.Collections.Generic.HashSet`1<T_REF>.IncreaseCapacity () [0x00028] in /private/tmp/source-mono-4.4.0-c7-baseline/bockbuild-mono-4.4.0-c7-baseline/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/System.Core/System/Collections/Generic/HashSet.cs:916
  at System.Collections.Generic.HashSet`1<T_REF>.AddIfNotPresent (T_REF) [0x000d4] in /private/tmp/source-mono-4.4.0-c7-baseline/bockbuild-mono-4.4.0-c7-baseline/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/System.Core/System/Collections/Generic/HashSet.cs:984
  at System.Collections.Generic.HashSet`1<T_REF>.Add (T_REF) [0x00000] in /private/tmp/source-mono-4.4.0-c7-baseline/bockbuild-mono-4.4.0-c7-baseline/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/System.Core/System/Collections/Generic/HashSet.cs:374
  at Microsoft.CodeAnalysis.ArrayBuilder`1<T_REF>.SelectDistinct<S_REF> (System.Func`2<T_REF, S_REF>) <IL 0x0002f, 0x00160>
  at Microsoft.CodeAnalysis.CSharp.CSharpCompilation.get_GlobalNamespace () <IL 0x0003c, 0x001e9>
  at Microsoft.CodeAnalysis.CSharp.BinderFactory/BinderFactoryVisitor.VisitCompilationUnit (Microsoft.CodeAnalysis.CSharp.Syntax.CompilationUnitSyntax,bool,bool) <IL 0x0014c, 0x00738>
  at Microsoft.CodeAnalysis.CSharp.BinderFactory/BinderFactoryVisitor.VisitCompilationUnit (Microsoft.CodeAnalysis.CSharp.Syntax.CompilationUnitSyntax) <IL 0x0000f, 0x00054>
Comment 1 Marek Safar 2016-06-17 09:43:29 UTC
Another symptom of known issue #39832. Mono cannot reliably run Roslyn

*** This bug has been marked as a duplicate of bug 39832 ***