Bug 41816 - Android builds aren't including classes.dex
Summary: Android builds aren't including classes.dex
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 6.1.0 (C7)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2016-06-14 19:36 UTC by Stephen Shaw
Modified: 2017-10-04 15:55 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Stephen Shaw 2016-06-14 19:36:53 UTC
If you build on the commandline the classes.dex is included, but if you build in XS it doesn't get included.
Comment 2 Greg Munn 2016-06-17 15:58:00 UTC
Jon and I aren't sure exactly why there is an issue with this when building in XS but we managed to get some more data on what was happening. He's continuing to look into it.
Comment 3 Greg Munn 2016-06-17 15:58:28 UTC
moving to android for the time being whilst his investigation is underway.
Comment 4 Stephen Shaw 2016-08-25 15:49:33 UTC
Did we ever figure out what was going on with this? Was this because of Microsoft.Bcl target files?