Bug 41784 - Xaml Forms Previewer
Summary: Xaml Forms Previewer
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Xamarin.Forms Previewer (show other bugs)
Version: Trunk
Hardware: Macintosh Mac OS
: High blocker
Target Milestone: (C8)
Assignee: Vinicius Jarina
URL:
: 42190 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-14 05:36 UTC by Mir Majeed
Modified: 2016-06-29 05:17 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin Studio 6.0 log files (36.94 KB, application/zip)
2016-06-14 17:43 UTC, Mir Majeed
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Mir Majeed 2016-06-14 05:36:05 UTC
# Steps to reproduce
Try to open any xaml file

# Expected behavior
File should open in xaml viewer

# Actual behavior
throws error "object reference not set to instance of an object"

# Supplemental info (logs, images, videos)
Xamarin Studio 6.1 Build 4963

# Test environment (full version information)
Comment 1 Alan McGovern 2016-06-14 17:35:04 UTC
Can you attach the log files from the session where it crashed?
Comment 2 Mir Majeed 2016-06-14 17:43:49 UTC
Created attachment 16322 [details]
Xamarin Studio 6.0 log files

Attached Xamarin Studio log files
Comment 3 Vinicius Jarina 2016-06-16 03:12:04 UTC
Hi Mir Majeed

I have recently fixed an issue with Xaml previewer that could throw a NRE
Comment 5 Mir Majeed 2016-06-16 22:26:35 UTC
Hi Vinicius,

Thanks for the info. When will this fix be available in the alpha channel?

Mir
Comment 7 Alan McGovern 2016-06-27 11:57:52 UTC
*** Bug 42190 has been marked as a duplicate of this bug. ***
Comment 8 xamarin-release-manager 2016-06-28 16:27:42 UTC
Fixed in version 6.1.0.5072 (master)

Author: Alan McGovern
Commit: 404ebeaa09454d722328377c1fc27f4e391f1d65 (xamarin/md-addins)
Included in Commit: 29b256f9c105fbb1abf834c530f2f91e90a3201f (mono/monodevelop)