This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 41727 - Document Outline Pad - When document outline pad is floating and and item is clicked the caret is not moved to item on text editor
Summary: Document Outline Pad - When document outline pad is floating and and item is ...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor (show other bugs)
Version: 2.0 Alpha 2
Hardware: PC Mac OS
: --- normal
Target Milestone: (C8)
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2016-06-11 03:13 UTC by Ricardo
Modified: 2016-09-26 15:59 UTC (History)
7 users (show)

See Also:
Tags: releasenote
Is this bug a regression?: ---
Last known good build:


Attachments

Description Ricardo 2016-06-11 03:13:25 UTC
I use the document outline pad a lot of, but the last version if you click on any item on it, just the text windows is scrolled, the caret cursor is not move to item in the text editor. Above follow my installation description:

Xamarin Studio Community
Version 6.1 (build 817)
Installation UUID: a582073a-5203-439a-ad3d-13814910eaf4
Runtime:
	Mono 4.4.0 (mono-4.4.0-branch/fcf7a6d) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000148

NuGet
Version: 3.3.0.0

Xamarin.Profiler
Not Installed

Apple Developer Tools
Xcode 7.3.1 (10188.1)
Build 7D1014

Xamarin.Android
Version: 6.1.99.224 (Xamarin Studio Community)
Android SDK: /Users/ricardo/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.8.0_77"
Java(TM) SE Runtime Environment (build 1.8.0_77-b03)
Java HotSpot(TM) 64-Bit Server VM (build 25.77-b03, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

Xamarin Android Player
Not Installed

Xamarin.iOS
Version: 9.9.0.719 (Xamarin Studio Community)
Hash: 3afb4af
Branch: master
Build date: 2016-04-24 15:13:41-0400

Xamarin.Mac
Version: 2.9.0.719 (Xamarin Studio Community)

Build Information
Release ID: 601000817
Git revision: 2335763551f9db8296b08542035977b899b7f3b7
Build date: 2016-04-25 10:45:36-04
Xamarin addins: 7f8c9ab2a981143a87fbd5adbde3f5890a838fde
Build lane: monodevelop-lion-cycle8-preview

Operating System
Mac OS X 10.11.5
Darwin MacBook-de-Ricardo-Soares.local 15.5.0 Darwin Kernel Version 15.5.0
    Tue Apr 19 18:36:36 PDT 2016
    root:xnu-3248.50.21~8/RELEASE_X86_64 x86_64

Enabled user installed addins
Addin Maker 1.3.2
MSBuild Editor 1.1.2
xUnit.NET 2 testing framework support 0.6.2
Manifest.addin 0.0.0.0
Comment 1 xamarin-release-manager 2016-06-13 10:19:07 UTC
Fixed in version 6.1.0.4632 (master)

Author: Mike Kr??ger
Commit: 68e2157043e29549c365297147096affb247dc50 (mono/monodevelop)
Comment 5 Shruti 2016-07-07 10:43:25 UTC
Thanks @Mike for your quick response all time!

@Ricardo, It would be great if you please check this issue at your end with latest Beta XS 6.0.2.41 and update us the behaviour of this.
Comment 6 xamarin-release-manager 2016-07-08 14:22:19 UTC
Fixed in version 6.0.2.54 (cycle7)

Author: Greg Munn
Commit: 17fb20a2351df15472eb6b224076256d317ba4cf (mono/monodevelop)
Comment 7 Ricardo 2016-07-08 14:54:18 UTC
Hi, 


Jatin mine is like the video you made. 


But the keyboard navigation is not made like Mike write. This is my claim. I like like before the keyboard cursor move to the place of the item I clicked. 


thanks.
Comment 8 Kyle White 2016-07-14 17:47:51 UTC
@Ricardo, 

I have checked again that our most recent beta this issue is resolved. When clicking on items in the Document Outline, the keyboard cursor is correctly moving to the location.

Please have a look at my screen cast: http://screencast.com/t/L6C3J0HYGx

If you are still experiencing a problem with the builds available in the Beta channel, please let us know. 

Kyle
Comment 9 Arpit Jha 2016-07-26 06:10:36 UTC
I have checked this issue with latest C7SR1 builds XS  6.0.2 (build 71) and observed that issue still exist.

Steps I have followed:
1.Create an project in XS.
2. Add a class and implement following code snippet

https://gist.github.com/Arpit360/a5ab95db4c4801597c45299d53faeb27

3. Set cursor in line //here is cursor

4. Move to Document Outline.

5. click on any properties pad.

Observed that after click on properties cursor not moved to text editor.

For now, I am reopening this issue.

Screencast : http://www.screencast.com/t/zxmt7GzgOH

Environment Info: https://gist.github.com/Arpit360/0f36c87d0735f546be703a18dfcab53b
Comment 10 Arpit Jha 2016-07-26 11:18:33 UTC
An update to comment 9:

After click on properties in Document outline pad, I tried to write some code from keyboard but unable to write.
Comment 11 Arpit Jha 2016-07-26 11:41:12 UTC
I have again tried and this time I find a workaround :
if We dock the document outline pad then its works for me.
Comment 13 xamarin-release-manager 2016-07-29 10:33:07 UTC
Fixed in version 6.2.0.259 (master)

Author: Mike Kr??ger
Commit: a6fa061869b666b993014dd222276b9eb2e6800d (mono/monodevelop)
Comment 14 xamarin-release-manager 2016-07-29 11:50:51 UTC
Fixed in version 6.1.0.5289 (cycle8)

Author: Lluis Sanchez
Commit: fedb7065987c351876bd5a93c824b0bd4df595b6 (mono/monodevelop)

Note You need to log in before you can comment on or make changes to this bug.