Bug 41694 - Roslyn doesn't "load" in projects that XS doesn't support
Summary: Roslyn doesn't "load" in projects that XS doesn't support
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding (show other bugs)
Version: 6.0.0 (C7)
Hardware: PC Mac OS
: Low normal
Target Milestone: C7SR1
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2016-06-10 11:55 UTC by Ryan Alford
Modified: 2016-07-01 12:40 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Ryan Alford 2016-06-10 11:55:46 UTC
I just upgraded to XS 6, and I am running into a problem. I have an old Windows Mobile project that I am converting to a Xamarin.Android application. Over the past 8 months or so, I have been opening this project in XS, receiving an error about an unsupported project type, and continuing to navigate around the code when I need to.

However, with XS 6, this doesn't work anymore. There is no syntax highlighting and no "Go To Definition" or "Find All References". This has made it crazy difficult to navigate the code. 

This has worked perfectly fine in previous versions of XS. It would be nice if this worked again. I don't need the project to build or run. I just need to be able to navigate the code.
Comment 1 Mike Krüger 2016-06-10 15:10:22 UTC
Can you provide me the project in some way ?
Comment 2 Ryan Alford 2016-06-10 15:13:20 UTC
Sure. I will have to make it private as it's proprietary code.
Comment 3 Mike Krüger 2016-06-10 15:16:39 UTC
y you can maybe even remove most of the files 1-2 files in the project should be enough :)
Comment 5 xamarin-release-manager 2016-06-13 05:33:38 UTC
Fixed in version 6.1.0.4629 (master)

Author: Mike Kr??ger
Commit: 364654e20c5dc208ecd98ee23df358f88cabc7ec (mono/monodevelop)
Comment 7 Mike Krüger 2016-06-20 08:09:48 UTC
has already been merged :

https://github.com/mono/monodevelop/commit/55649d9551d6262f0964c8ae33f1d7d65556634e
Comment 9 Ryan Alford 2016-06-20 15:13:06 UTC
Is this a fix that will be just pushed out with the next alpha? Or will it go into a fix that will be released earlier?
Comment 10 Kyle White 2016-06-22 17:14:11 UTC
It will be in our next service release scheduled for about 1-2 weeks out.

Note You need to log in before you can comment on or make changes to this bug.