Bug 41674 - MSBuild is broken in mono 4.6
Summary: MSBuild is broken in mono 4.6
Status: VERIFIED FIXED
Alias: None
Product: Tools
Classification: Mono
Component: msbuild (show other bugs)
Version: 4.6.0 (C8)
Hardware: Macintosh Mac OS
: High major
Target Milestone: (C8)
Assignee: Alexis Christoforides
URL:
Depends on:
Blocks:
 
Reported: 2016-06-09 21:48 UTC by Peter Collins
Modified: 2016-07-29 18:32 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: mono-4.4.0-branch

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Peter Collins 2016-06-09 21:48:31 UTC
I'm filing this to avoid any possible confusion between this issue and what was reported in bug #41567.

Attempting to invoke msbuild from command line fails with the following:

> /usr/local/bin/msbuild: line 2: /Users/xamarinqa/qabot/data/lanes/3322/4a655c66/source/QualityAssurance/Automation/XQA/XQA.DesktopMono/bin/Debug/@bindir@/mono: No such file or directory
> /usr/local/bin/msbuild: line 2: exec: /Users/xamarinqa/qabot/data/lanes/3322/4a655c66/source/QualityAssurance/Automation/XQA/XQA.DesktopMono/bin/Debug/@bindir@/mono: cannot execute: No such file or directory
##### Environment #####
Operating System: Mac OS X 10.11.5
Repo Name: mono.git
Branch Name: mono-4.5.1
Build Revision: 4a655c66f74e7caa150912aa0d7ebe2e5aeded26
Comment 1 Peter Collins 2016-07-08 15:51:10 UTC
I'm still able to reproduce this against mono 4.6.0. This behavior is a regression from mono 4.4 where it previously worked.

##### Supplemental Info #####
Log File #1:	http://xqa.blob.core.windows.net/gist/log-908d5978fece4d58bf081f3b080c55f8.txt

##### Environment #####
Operating System: Mac OS X 10.11.5
Repo Name: mono.git
Branch Name: mono-4.6.0
Build Revision: 5a919fe1e763a65f7935a56e0ba5164d5808f65d
Comment 2 Ankit Jain 2016-07-08 16:43:23 UTC
This looks like an issue with the installer. Assigning to @lexas .
Comment 3 Peter Collins 2016-07-28 13:05:06 UTC
Missing bockbuild fix was back-ported in bockbuild/xamarin/f2780cbef6e3e9c20cc8462b85be6a47c65ce9b9.
Comment 4 Peter Collins 2016-07-29 18:32:59 UTC
Verified fixed in mono-4.6.0-branch/104b14ecf9231